2011年7月13日

[ruby-list:48204] rails3、RUBY1.9.2、mongrel1.1.5でckeditorの利用の問題

中国杭州の程黎航(チェン リハン)と申します。

現在、Rails3、RUBY1.9.2、mongrel1.1.5の構成で開発を進めています。
ckeditor3.5.4(gemライブラリ)をインストールした後、mongrel1.1.5を起動できなくなりました。

技術不足で問題の発生原因が分からなく、解決できません。
解決策を教えていただけないでしょうか?

■プロセス
1.Rails3.0.7、RUBY1.9.2、mongrel1.1.5、mysql2で正常に開発を行って来ました。

2.ckeditorを利用するため、プロジェクトにckeditor3.5.4をインストールしました。

  インストールに、下記問題が発生して、解決策で対応しました。
   ?bundle install に、mongrelをrequireできない問題が発生したため、Gemfileからgem mongrelをコメントしました。
   (問題発生した時のログは、下記ログ情報と同じ見たい。)
   ?bundle install に、mysql2をインストールできないため、gem mysql2を
gem ruby-mysql に変更しました。
   ?rails generate ckeditor:baseに、msvcrt-ruby18.dllが存在しないため、動作できない問題を発生したため、
     msvcrt-ruby18.dllをダウンロードしてRUBY1.9.2のホーム\binにコピーしました。
3.Rails3.0.7、RUBY1.9.2、mongrel1.1.5、ruby-mysql、ckeditorで、mongrelを起動できなくなりました。

■環境
WindowsXP
RUBY 1.9.2p180(2011-02-18)[i386-mingw32]
mysql 5.0.18-nt via TCP/IP
Rails 3.0.7
ruby-mysql 2.9.4
mongrel 1.1.5
ckeditor 3.5.4

■ログ情報
C:\works\mybbs>rails server mongrel
C:/works/mybbs/vendor/ruby/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/http11.so:
[
BUG] Segmentation fault
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

-- control frame ----------
c:0025 p:-9938314 s:0072 b:0072 l:000071 d:000071 TOP
c:0024 p:---- s:0070 b:0070 l:000069 d:000069 CFUNC :require
c:0023 p:0095 s:0066 b:0066 l:000065 d:000065 TOP
C:/works/mybbs/vendor/ruby/
1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/mongrel.rb:12
c:0022 p:---- s:0064 b:0064 l:000063 d:000063 FINISH
c:0021 p:---- s:0062 b:0062 l:000061 d:000061 CFUNC :require
c:0020 p:0026 s:0058 b:0058 l:000039 d:000057 BLOCK
C:/Ruby192/lib/ruby/gems/1.
9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:69
c:0019 p:---- s:0055 b:0055 l:000054 d:000054 FINISH
c:0018 p:---- s:0053 b:0053 l:000052 d:000052 CFUNC :each
c:0017 p:0091 s:0050 b:0050 l:000039 d:000049 BLOCK
C:/Ruby192/lib/ruby/gems/1.
9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:67
c:0016 p:---- s:0045 b:0045 l:000044 d:000044 FINISH
c:0015 p:---- s:0043 b:0043 l:000042 d:000042 CFUNC :each
c:0014 p:0046 s:0040 b:0040 l:000039 d:000039 METHOD
C:/Ruby192/lib/ruby/gems/1.
9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:55
c:0013 p:0021 s:0036 b:0036 l:000035 d:000035 METHOD
C:/Ruby192/lib/ruby/gems/1.
9.1/gems/bundler-1.1.pre.5/lib/bundler.rb:123
c:0012 p:0079 s:0032 b:0032 l:000031 d:000031 TOP
C:/works/mybbs/config/appli
cation.rb:7
c:0011 p:---- s:0030 b:0030 l:000029 d:000029 FINISH
c:0010 p:---- s:0028 b:0028 l:000027 d:000027 CFUNC :require
c:0009 p:0016 s:0024 b:0024 l:000015 d:000023 BLOCK
C:/works/mybbs/vendor/ruby/
1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:28
c:0008 p:---- s:0021 b:0021 l:000020 d:000020 FINISH
c:0007 p:---- s:0019 b:0019 l:000018 d:000018 CFUNC :tap
c:0006 p:0468 s:0016 b:0016 l:000015 d:000015 TOP
C:/works/mybbs/vendor/ruby/
1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:27
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :require
c:0003 p:0061 s:0006 b:0006 l:001cf4 d:000524 EVAL script/rails:6
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:001cf4 d:001cf4 TOP
---------------------------
-- Ruby level backtrace information ----------------------------------------
script/rails:6:in `<main>'
script/rails:6:in `require'
C:/works/mybbs/vendor/ruby/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:27:in
`<top (required)>'
C:/works/mybbs/vendor/ruby/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:27:in
`tap'
C:/works/mybbs/vendor/ruby/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:28:in
`block in <top (required)>'
C:/works/mybbs/vendor/ruby/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:28:in
`require'
C:/works/mybbs/config/application.rb:7:in `<top (required)>'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler.rb:123:in
`req
uire'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:55:
in `require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:55:
in `each'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:67:
in `block in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:67:
in `each'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:69:
in `block (2 levels) in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.5/lib/bundler/runtime.rb:69:
in `require'
C:/works/mybbs/vendor/ruby/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/mongrel.rb:1
2:in `<top (required)>'
C:/works/mybbs/vendor/ruby/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/mongrel.rb:1
2:in `require'

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension
libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html


投稿者 xml-rpc : 2011年7月13日 11:49
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105278
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。