2011年5月 4日

[ruby-list:48053] Re: ruby 1.9.2とRails3 へのアップグレード

信岡さん

返事をありがとうございます。
rvmのバッグかなぁ。。。

アスカル

2011/5/4 Y. NOBUOKA <nobuoka@xxxxx>:

> アスカルさん
>
> 信岡です。
>
>> なぜかrvmがなくなったので再インストールしました。
>> $cd rvm
>> $ ./install
>> を実行すると
>>
>> .bashrc あるいは .bash_profileの
>> 一番最後に
>> [[ -s "/Users/askar75/./rvm/scripts/rvm" ]] && source
>> "/Users/askar75/./rvm/scripts/rvm"
>> を入れるようにメッセージが出ていたので、そのままコピ&ペーストしました。
>
> 確かにその通りですね。
> 以前は ~/.rvm にインストールされていたはずなのですが、今さっき試してみたところ
> アスカルさんのパス設定にするよう私のほうでも表示されました。 申し訳ないです。
>
>> また同じく、rubyそのもの、バージョン1.9.2をデフォールトに設定しましたが、
>> $ri CSVを実行すると結果はNothing known about CSV
>> つまりデータ無し
>>
>> $gemを実行すると
>> /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:28:in
>> `<top (required)>': uninitialized constant Gem::ConfigFile (NameError)
>> from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
>> `require'
>> from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
>> `require'
>> from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:8:in
>> `<top (required)>'
>> from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
>> `require'
>> from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
>> `require'
>> from /Users/askar75/./rvm/rubies/ruby-1.9.2-p180/bin/gem:13:in `<main>'
>
> 私も先ほど RVM の公式サイトに書いてある手順 [1] に沿って rvm のインストールを
> しなおしてみたのですが、アスカルさんと同じ状態になってしまいました。
> (Ubuntu を使用しています。)
> 1, 2 ヶ月ほど前にインストールしたときはちゃんとできたのですが。。
> まだ原因はわかっていませんが、とりあえず同じ状況になったことだけお知らせいたします。
>
> [1] https://rvm.beginrescueend.com/rvm/install/
>
> --
> 信岡 ゆう (NOBUOKA Yu)
>
>


投稿者 xml-rpc : 2011年5月 4日 19:13
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/103604
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。