2011年5月 4日

[ruby-list:48041] ruby 1.9.2とRails3 へのアップグレード

おはようございます。

OSはMAC OS X 10.6.7です。

ruby 1.9.2へのアップグレードは
下記のリンクを参考にしました:

http://d.hatena.ne.jp/yoshiob/20110324/1300938503

http://www.iex3.info/archives/1154
http://iandeth.dyndns.org/mt/ian/archives/000686.html

1)ruby 1.9.2p180 (2011-02-18 revision 30909)
[x86_64-darwin10.7.0]へのアップグレードはできましたが
例えば ri CVS を起動すると下記のメッセージがでます:
/Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/version.rb:143:in
`<top (required)>': uninitialized constant Gem::Version (NameError)
from <internal:gem_prelude>:190:in `const_get'
from <internal:gem_prelude>:190:in `const_missing'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/paths.rb:71:in
`block in gemdirs'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/paths.rb:67:in
`each'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/paths.rb:67:in
`gemdirs'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/paths.rb:43:in
`each'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/driver.rb:330:in
`initialize'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/driver.rb:308:in
`new'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rdoc/ri/driver.rb:308:in
`run'
from /Users/askar75/./rvm/rubies/ruby-1.9.2-p180/bin/ri:9:in `<main>'

しかし、ri -v のバージョン確認はエラーがなく結果はri 2.5.8となっています。

ruby 1.9.2のインストールは最後まで行っていないということでしょうか。

2)ついでにRails3もインストールしたかったのですが、
gem install railsだと
/Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:28:in
`<top (required)>': uninitialized constant Gem::ConfigFile (NameError)
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:8:in
`<top (required)>'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /Users/askar75/rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /Users/askar75/./rvm/rubies/ruby-1.9.2-p180/bin/gem:13:in `<main>'
がでます。

こういった問題を解決するにはどこを参考にすれば宜しいでしょうか。

宜しくお願いします、
アスカル


投稿者 xml-rpc : 2011年5月 4日 10:29
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/103556
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。