2011年2月 9日

[ruby-list:47854] Re: ruby1.9での文字列について

なるほど。解決です。ありがとうございました。

2011年2月9日9:54 Takahiro Kambe <taca@xxxxx>:
> In message <AANLkTimcEFu6cuar6SCJ=4crQ2Wf3RQyXfTVdgu3=K9d@xxxxx>
> on Wed, 9 Feb 2011 09:42:43 +0900,
> Nobuyuki Inaba <nobuyuki.inaba@xxxxx> wrote:
>> それで、プログラムを実行するとき、ruby1.9のときは、force_encodingをし
>> て、ruby1.8のときはそれをしないようにしたいと思いましたが、実行中の

>> rubyにそれを判断する方法をしりたいのですが、なにか特別な変数などある
>> のかと思いましたが見つけられませんでした。
>> 何度もすみませんが、実行中のrubyのバージョンをプログラム中に知る方法
>> はご存知ないでしょうか?
> 発想を転換してforce_encodingというメソッドを呼べるかどうか、最初に確認
> しておいてはどうでしょう?
>
> --
> 神戸 隆博 (かんべ たかひろ) at 仕事場
>
>


投稿者 xml-rpc : 2011年2月 9日 10:04
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/101875
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。