2011年2月 8日

[ruby-list:47844] Re: ruby1.9.1 と Rails3.0.3 について

むらたです。

2011年2月8日10:03 <eiichi_maekawa@xxxxx>:
> Rails3.0.3をRuby1.9.1に入れ、バージョンを確認したところ、
>
> D:\Ruby191>rails -v
>
> Rails 3 doesn't officially support Ruby 1.9.1 since recent stable

> releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2.
>
> You're running
> ruby 1.9.1p430 (2010-08-16 revision 28998) [i386-mingw32]
>
> Rails 3.0.3
>
> となり、セグメンテーションフォルトが、生じるとの注意書きですが、
> 1.9.1では、Rails3.0.3は、使用しないほうがいいのでしょうか?

使用しないほうがよいから注意しているのだと思います。
特別な事情がない限り従っておいたほうが安全です。

> 勉強のために、1.9.1にインストールしたのですが・・・

勉強されるんでしたら、Ruby を 1.9.2 にバージョンアップすることをお勧めします。

--
Kenta Murata
OpenPGP FP = 1D69 ADDE 081C 9CC2 2E54 98C1 CEFE 8AFB 6081 B062

本を書きました!!
『Ruby 逆引きレシピ』 http://www.amazon.co.jp/dp/4798119881/mrkn-22

E-mail: mrkn@xxxxx
twitter: http://twitter.com/mrkn/
blog: http://d.hatena.ne.jp/mrkn/


投稿者 xml-rpc : 2011年2月 8日 10:25
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/101864
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。