2010年12月28日

[ruby-list:47727] Date.parse("2010-12") がv1.8.7 でエラー

こんにちは。

既出かもしれませんが情報を見つけきれなかったので質問です。
v1.8.6 だとエラーにならないけど、1.8.7 だとエラーになりました。
これは仕様でしょうか?

$ ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-linux]


$ ruby -rdate -e 'p Date.parse("2010-12")'
/usr/local/lib/ruby/1.8/date.rb:956:in `new_by_frags': invalid date
(ArgumentError)
from /usr/local/lib/ruby/1.8/date.rb:1000:in `parse'
from -e:1

#師走の折、体調管理に気をつけましょう


投稿者 xml-rpc : 2010年12月28日 10:34
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100993
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。