2010年12月27日

[ruby-list:47717] Re: Windowsで1.9.2p136+zlibのインストール

あおきです。

> とりあえず、頂いた情報では再現ができないので追試すらままなり
> ません。

すみません。

> どこから入手したどのファイルですか?


http://zlib.net/zlib125-dll.zip

> これはrubyの配布物中の ext/zlib で実行したということでしょう
> か?

はい。

> ruby -rzlib -e0

先のメールと同じエラーダイアログが出て,コンソールは

<internal:lib/rubygems/custom_require>:29:in `require': 127: 指定されたプロシージャが見つかりません。
- c:/ap/ruby192-p136/lib/ruby/site_ruby/1.9.1/i386-msvcr71/zlib.so (LoadError)
from <internal:lib/rubygems/custom_require>:29:in `require'

となりました。

上記の.zipをダウンロードし直して,

C:\ap\ruby-1.9.2-p136\ext\zlib> ruby extconf.rb --with-zlib-include=c:\ap\zlib-125
namke
nmake install

まではOKで,

ruby -rzlib -e0

の結果は変わらずでした。

投稿者 xml-rpc : 2010年12月27日 14:16
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100982
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。