2009年7月 9日

[ruby-list:46195] Re: 1.8.6から1.8.7または、1.9へのバージョンアップ及びrailsのバージョンアップについて・

前川です。

okkezさん、ありがとうございました。

試してみましたが、結果は、以下でした。

C:\ruby\lib\ruby\gems\1.8>set http_proxy=http://プロキシサーバ名:ポート番号

C:\ruby\lib\ruby\gems\1.8>gem update rails -y
Updating installed gems...
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
getaddrinfo: no address associated with hostname.(SocketError)

エラーから類推すると、直接、外部のサーバへのアクセスは、
禁止しているようです。
(会社のシステムなので、ガチガチにガードしているようです。)
1.8.7にアップした後、確認し、だめな場合は、個別対応ですね・・・

1.8.6で使用しているrailsは、1.8.7でも、問題なく使用できるか、
どなたか、教えていただけませんか?
よろしくお願いします。

Rubyを始めて、1ヶ月足らずです。
皆さんのご協力、よろしくお願いします。

> okkez です。

> よくわからないなら 1.8.7 を使うといいと思います。
> 1.9.1 は標準添付以外のライブラリが対応していないことが多いです。

> rubygems proxy などのキーワードで検索して結果をよく読むと幸せになれる
> と思います。
> gem help install や gem help search なども参考になるでしょう。

>
> --
> okkez
> okkez000@xxxxx

投稿者 xml-rpc : 2009年7月 9日 08:56
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/86547
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。