2009年7月 7日

[ruby-list:46181] Re: ruby-chasen in 64bit machine

阪口です。

In message <20090707210714.070ccdaf.ksmakoto@xxxxx> 2009-07-07T21:07+0900,
"KISHIMOTO, Makoto" <ksmakoto@xxxxx> wrote:
> (1) 通常期待される結果になる(端末がUTF-8なのでnkfを通しています)

こちらですね。(というかテストしようとさっき全部入れ直しましたが:-)
少し前に csup した ports collection で portinstall したものですが、

関係バージョンを列挙しておきます。

ports でのバージョン: (/var/db/pkg/)
ja-chasen-2.4.4
ja-chasen-base-2.4.4
ja-ruby18-chasen-1.6_2
ruby+pthreads+oniguruma-1.8.7.72_1,1

% ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [amd64-freebsd7]

% chasen -V
ChaSen version 2.4.4 (c) 1996-2007 Nara Institute of Science and Technology
Grammar files are in ChaSen's new v-gram format.

という感じです。

PS. amd64 にして私は愛用の jvim+onew を諦めました。。なんといってもポインタを
int に代入しているらしき警告だらけで、どう見てもそれが原因で core dump
していたので。。(個人的には sizeof (int) != sizeof (void *) な gcc に
疑問を感じているけど、それだけ Cのコードが int が32ビットに依存している
ものばかりなんでしょうね。)
rubyや chasen周りではそういった警告は見てないと思います。
(見逃している可能性はありますが。)
--
阪口哲男@図書館情報メディア研究科.大学院.筑波大学
Tetsuo SAKAGUCHI.
Graduate School of Library, Information and Media Studies
University of Tsukuba, JAPAN.


投稿者 xml-rpc : 2009年7月 7日 22:28
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/86515
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。