2008年4月18日

[ruby-list:44844] Railsのインストールエラー [Fedora6.0]


はじめまして、emoseiと申します。

Fedora6.0にRailsをインストールしようとしたのですが、

# gem install rails ―include-dependencies
ERROR: While executing gem … (Gem::Exception)
SSL is not installed on this system


と出なりエラーとなってしまいました。

SSLはインストールされています。

# openssl version
OpenSSL 0.9.8b 04 May 2006

opensslがインストールされていても、
Railsがインストールできないという
ことで、少し調べてみたところ、

libopenssl-ruby
が必要だとわかり、インストールしようと思い、
以下のコマンドを実行しました。

# yum install libopenssl-ruby
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: libopenssl-ruby
Nothing to do

すると、libopenssl-ruby
が無いといわれてしまいました。

別の方法で、と思い、
# apt-get install libopenssl-ruby

をしたのですが、、

apt-getがなく、インストールしようにも、
Fedora6に入れるべきパッケージが見当たりませんでした。

この時点で手詰まりになってしまったのですが、
同様の現象を回避されたかたや、
上記手順の問題等指摘していただけるとありがたいです。

OSの情報は、

#uname -m
Linux localhost.localdomain 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16
14:37:32 EDT 2006 i686 i686 i386 GNU/Linux

その他情報

# ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i686-linux]
# gem -v
0.9.5

以上です。


投稿者 xml-rpc : 2008年4月18日 10:40
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/72283
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。