2008年2月 5日

[ruby-list:44572] Re: Q: 動的デバッグ方法

るびきち さん、

とても有益なアドバイスありがとうございます。
> ruby-breakpointはどうでしょうか?
> breakpointと書いた時点でirbに突入します。
> gem化されているのでインストールしてください。
> $ sudo gem install ruby-breakpoint

早速、以下のようにインストールし、
# sudo gem install ruby-breakpoint
Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed ruby-breakpoint-0.5.1
Installing ri documentation for ruby-breakpoint-0.5.1...
Installing RDoc documentation for ruby-breakpoint-0.5.1...

うまくいったようなので、プログラムに組み込んだのですが、
Runtime error がでます。
以下のようにプログラムを単純化し、
$ cat t.rb
require 'rubygems'
require 'breakpoint'
breakpoint
実行したら、
$ ruby t.rb
/usr/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/breakpoint.rb:21:in `of_caller':
Breakpoints are not currently working with Ruby 1.8.5 (RuntimeError)
from usr/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/breakpoint.rb:543:in
`breakpoint'
from -:3
となり、Ruby 1.8.5では動作しないと出ます。これはruby本体を別のバージョン
すればよいのでしょうか? それとも ruby 1.8.5 にあったruby-breakpoint が
あるのでしょうか?
インストールの仕方がまずいようなのですが、どのように対処すべきか?
分かりません。どなたかご教示よろしくお願いいたします。

もりた


投稿者 xml-rpc : 2008年2月 5日 09:41
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/69483
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。