2006年4月15日

[ruby-list:42034] Re: cygwin で ruby/gtk

むとうさま、ご回答ありがとうございます。

X不要ということで、Win32版を試してみました。
しかしやはりどうもうまく行きません。
以下のサイトに書いてあるとおり、
http://ruby-gnome2.sourceforge.jp/ja/hiki.cgi?cmd=view&p=%A5%A4%A5%F3%A5%B9%A5%C8%A1%BC%A5%EB%A5%AC%A5%A4%A5%C9+Windows%CA%D4&key=win32

最新版の

ruby:ruby184-16_rc1.exe
ruby/Gtk:ruby-gtk2-0.14.1-1-i386-msvcrt-1.zip
Gtk:gtk-win32-aio-2.4-rc22.exe
をダウンロードし、この順番でインストールしました。
また、環境変数PATHには以下のエントリがあります。
%GTK_BASEPATH%\bin;%GTK_BASEPATH%\lib;C:\rubywin\bin;

Dosプロンプトを使って、以下のコマンドを試してみました。
%>ruby -e "require 'gtk2'"

すると、以下のエラーが出ました。
何がいけないのでしょうか?アドバイスをよろしくお願いいた
します。

プロシージャエントリポイント
libiconv_set_relocation_prefix
がダイナミックリンクライブラリiconv.dllから見つかりませ
んでした。

C:/rubywin/lib/ruby/site_ruby/1.8/i386-msvcrt/glib2.so:
127:
指定されたプロシージャが見つかりません。 -
C:/rubywin/lib/ruby/site_ruby/1.8/i386-msvcrt/glib2.so
(LoadError)
from
C:/rubywin/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
from C:/rubywin/lib/ruby/site_ruby/1.8/glib2.rb:68
from
C:/rubywin/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
from C:/rubywin/lib/ruby/site_ruby/1.8/gtk2.rb:1
from
C:/rubywin/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
from -e:1


--------------------------------------
Celebrate Yahoo! JAPAN 10th Anniversary
http://pr.mail.yahoo.co.jp/10thann/

投稿者 xml-rpc : 2006年4月15日 15:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/41891
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。