2010年12月20日

[plamo:30874] Re: Firefox 3.6.13について質問します。

加藤泰文です.

>>> On Sun, 19 Dec 2010 22:57:06 +0900
in message "[plamo:30872] Firefox 3.6.13について質問します。"
nori-san wrote:

> 早速、ブラウズしてみたのですが、yahooのトップページの表示が変です。
> しかも、

>   Yahoo!JAPANトップページの全機能をご利用いただくには、下記の環境が必要となります。
>   Firefox 3.0以上
> と表示されています。

User-Agent を見てるみたいですね.Plamo パッケージの User-Agent として
送られるのは,3.6.13 だと
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.2.13) Gecko/20101210 Namoroka/3.6.13 GTB7.1
こんな感じの文字列です.これだと確かにおっしゃるような表示が出ます.こ
この "Namoroka" の部分が引っかかるみたい.ここを
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.2.13) Gecko/20101210 Firefox/3.6.13 GTB7.1
とするだけで普通に表示されました.

対策としては,
1) mozilla 純正の firefox をダウンロードして使用する.これだとちゃん
と Firefox の文字列が入った User-Agent が送出されるはずです.
2) firefox のアドオンで User-Agent を書き換えられる addon を入れる.
例えば "User Agent Switcher" とか.これでデフォルトで入っている適
当なブラウザに切り替えて使えば,他に Linux 版 Firefox は対応して
ないとか怒られるところでも対応出来る可能性があります.User-Agent
で判断しているサイトに限りますが.試しに Internet Explorer 8 の設
定で Y! にアクセスしても OK でした.:-p
3) Google Chrome を使う.こっちの方が軽いので最近はこちらを使う方が
多いです.こちらだと Plamo のパッケージでも問題なく Y! は表示され
ました.Update を結構しているので Plamo パッケージ使う場合でも,
マメに Plamo の公式ページをご覧いただいて,Update してくださいね.

--
==============================================
(((( 加藤泰文
○-○ karma @ jazz.email.ne.jp
==============================================
(Web Page) http://www.ten-forward.ws/
==============================================

投稿者 xml-rpc : 2010年12月20日 11:52
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100856
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。