2010年9月11日

[plamo:30767] Re: キーマップがおかしい


こじま@こちらを立てれば,あちらが立たず,だなぁ,,です.

From: m.umeda@xxxxx
Subject: [plamo:30766] Re: キーマップがおかしい
Date: Sat, 11 Sep 2010 03:05:41 +0900

> # /sbin/xfplamoconfig

>
> % startx
>
> をしたのですが次のエラーが出て止まりました。
>
> Bfore reporting problems,check http://wiki.x.org
> to make sure that you have the latest version.
> Makkers:(--) probed,(xx) from configfile,(==)
> default setting,(++) from command line,(!!)notice,(II)
> informational,(WW)woring,(EE)error,(NI) not implemented,
> (??) unknown.
> (==) Logfile:"/var/log/Xorg.0.log",Time fri sep 10 16:26:15 2010
> (==) Useing configfile:"/etc/X11/xorg.conf"
> (EE) Failed to load module "freetype"(module dose not exisist,0)
> (EE) Failed to load module "typc1"(module dose not exisist,0)
> (EE) Failed to load module "record"(module dose not exisist,0)
> (EE) Failed to load module "xtrp"(module dose not exisist,0)
> (EE) intel(0):N0 valid modes.
> (EE) Screen(s) found, but none have a usabele configuration.
>

Plamo-4.73 では,諸般の事情で Intel のビデオカードのドライバをダウング
レードしているので,4.72 では動いていたビデオチップが動かなくなっている
のでしょう.

4.72 で使っていたドライバは contrib/xf86_video_intel-2.10.0-i586-P1.tgz に
移しているので,updatepkg でこのドライバをインストールして,/etc/modprobe.conf に
options i915 modeset=1 とすることで,動くようにならないですかね?

# 詳細は README.EUC を参照のこと

> "intel"→"vesa"に変更したら、正常にXfceが起動しました。これは他所のディストリで
> 教わった知識で、恐縮ですが、ここが"Intel"等になって居て、Xが起動しない場合、"vesa"
> に置き換えると、起動する事が有ると聞いたからです。

vesa のドライバは,最大公約数的な業界標準の機能だけを使ったドライバで,
各メーカーがそれぞれ工夫をこらしているビデオカード固有の機能は使わない
からパフォーマンス的にはかなり劣るので,可能ならば vesa 以外の固有ドラ
イバを使う方がいいでしょうね.

--------
こじま

投稿者 xml-rpc : 2010年9月11日 09:47
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/98293
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。