2010年7月24日

[plamo:30690] ffmpeg から lameについて

今夜もお暑うございます、M.H です。

Plamo-test/for-4.7x にある ffmpeg-0.6 をインストールしてみました。
# たぶん、GStreamer 以下の gstreamer 関連以外のライブラリが必要?
# gstreamer 関連は glib-2.22.x にしないとダメなのかな???

ffmpeg -i -ar 4410 -ab 128 input.flv output.mp3
などと実行すると、最後に、

[libmp3lame @ 0x807ba60]lame: output buffer too small (buffer index: 9195, free bytes: 597)
などと表示されてエラーになります。

これは ffmpeg の問題ではなくて(--enable-libmp3lame で make されているので、
external なライブラリが使われる)、lame-3.98.2 の問題らしく、
lame-3.98.4 にバージョンアップするとエラーが出なくなります。

Thanks!
-M.H

投稿者 xml-rpc : 2010年7月24日 23:57
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/97221
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。