2009年8月31日

[plamo:30118] Re: plamo4.6でKeyboard配列がJP106仕様にならず

すみません、PC Hard諸元 M/B追記します。

M/B:TA690G AM2 Biostar製

----- Original Message -----
From: "Kenichi_ Mitsuhashi" <micchi-@xxxxx>
To: <plamo@xxxxx>
Sent: Monday, August 31, 2009 10:01 PM

Subject: [plamo:30117] Re: plamo4.6でKeyboard配列がJP106仕様にならず


> 松田様、名倉様
>
>
> お世話になっております、三橋です。
> いろいろとご助言、ありがとうございます。
>
>
> PC環境の諸元は、下記になります。
>
> CPU:AMD Athlon 64 X2 4200
> Memory:3GB UMAX NOVAX TECHINOLOGIS,Inc.製
> HD:Western Digital WD3200SD 320GB
> Keyboard:ELECOM製 PS/2タイプ
> Video Card:NDIVA GeForce 6600
>
>
> 余談ですが、plamo4.2の時も実はKey配列問題が発生しておりましたが、
> 上記諸元でKeyboadをノンブランド品やらELECOM製のものとかに変えると認識できるようになりました。
> 設定は何も変更していません。
> その後、Keyboadを元に戻しても、しっかりJP106配列のままで動作していました。
>
> この原因も分かっていません。
> もし、ご経験、知見をお持ちでしたら、ご教授頂けると幸いです。
>
> Linux初心者ですが、不具合などを通じて知識を高めていきたいです。
>
> よろしくお願いします。
>
>
>
>
>
> ----- Original Message -----
> From: "名倉昭一" <nagura-s@xxxxx>
> To: <plamo@xxxxx>
> Sent: Monday, August 31, 2009 11:44 AM
> Subject: [plamo:30116] Re: plamo4.6でKeyboard配列がJP106仕様にならず
>
>
>> 名倉@45W版SocketAM3CPU購入待機中
>>     シビレがきれてATOMでお茶を濁し中 です。
>>
>>> 松田です
>>>
>>> 却って動作が変になる助言をしてすみません.
>>> 参考にならないかもしれませんが,私の経験をお話しします.
>>>
>>> 私の自宅にあるLinux機は,チップセットAMD780Gを積んでいます.
>>> (内臓のRadeon HD3200でfgrlxを動かすのにもだいぶ苦労しました)
>>>
>>> Plamo-4.6を導入した際にキーボードレイアウトをjpに指定したのにも関わらず,
>>>
>>> usとなってしまう現象に悩み,AutoAddDevicesというオプションに行き着きました.
>>> これをfalseに明示的に指定しないと,次のようなXorg.0.logが残り,
>>> 正常にjpキーボード組み込んだという記述の後に,
>>> 明らかに余計な?デバイスを組み込む記述が記録されていました.
>>> (マウスもxorg.confで明示的に指定したドライバに加えて,
>>> 余計なドライバーが組み込まれるのですが,
>>> 自動認識された設定でちゃんと動いていたので気づかなかったです.)
>>>
>>> (II) config/hal: Adding input device AT Translated Set 2 keyboard
>>> (**) AT Translated Set 2 keyboard: always reports core events
>>> (**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
>>> (II) AT Translated Set 2 keyboard: Found keys
>>> (II) AT Translated Set 2 keyboard: Configuring as keyboard
>>> (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard"
>>> (type:
>>> KEYBOARD)
>>> (**) Option "xkb_rules" "base"
>>> (**) AT Translated Set 2 keyboard: xkb_rules: "base"
>>> (**) Option "xkb_model" "evdev"
>>> (**) AT Translated Set 2 keyboard: xkb_model: "evdev"
>>> (**) Option "xkb_layout" "us"
>>> (**) AT Translated Set 2 keyboard: xkb_layout: "us"
>>>
>>>
>>> > 名倉 です。
>>> >
>>> >> 名倉様、松田様
>>> >>
>>> >>
>>> >> ご教授ありがとうございました。
>>> >>
>>> >>
>>> >> 結果は下記の通りです。
>>> >>
>>> >> 名倉さんの方法=OK
>>> >>
>>> >> 松田さんの方法=NG
>>> >>
>>> >> もともと自分のxorg.confには、Option "AutoAddDevices" "on"の記述がなく
>>> >> この行をOption "AutoAddDevices" "false"
>>> >> に設定し追加したのですが、X Windowが立ち上がらなくなり、またマウスの動作が異常になったため、今回は不採用にしました。
>>> >>
>>> >> 自分のオリジナルファイルは
>>> >> Section "InputDevice"
>>> >> Identifier "Keyboard1"
>>> >> Driver "kbd"
>>> >> Option "XkbModel" "jp106"
>>> >> Option "XkbLayout" "jp"
>>> >>  EndSection
>>> >>
>>> >> となっていました。
>>> >
>>> >   よかったでもどんなハードだとこのようなxorg.confが生成されるのだろう?
>>> >   参考までにハードウエア情報を貼っていただければと思います。
>>> >
>>> >
>>> > 以下 略
>>> >
>>
>>   貴重な情報ありかとうございます。 手元のマシン再点検してみます。
>>
>>> --
>>> -------------------------------------------------------------------
>>> mmm mmm | matuda@xxxxx
>>> ((^_^)) <- -> | 松田七美男@東京電機大学 環境物質化学科 教授
>>> { } ({ }) | 〒101-8457 千代田区神田錦町2-2
>>> _I I_ _I_ | Tel:03(5280)3402 Fax:03(5280)3570
>>
>>
>>
>>
>
>

投稿者 xml-rpc : 2009年8月31日 22:10
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/88148
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。