2009年7月27日

[plamo:29990] Re: plamo4.6 の key

> 加藤泰文です.
>
> >>> On Sat, 25 Jul 2009 00:18:29 +0900 (JST)
> in message "[plamo:29967] plamo4.6 の key"
> 早間義博-san wrote:
>
> > x を起動すると 101 キーボードになってしまいます(8 の上段は'*') 。
> > キー番号は忘れましたが右上の '\|' と 右下の '\_' は入力が出来ません。

> > # どちらのキーボードを使用しても同じです。
>
> 私も途中に切替器挟んだりしているので,色々とキーボード廻りはややこしく
> なってます.VMWare で '_' が入力出来ないとか以前もあった気がするなあ.
>
> 根本解決じゃないのかも知れませんが,
> http://www.vmware.com/files/jp/pdf/ws65_manual.pdf
> の 338 ページ辺りから参考になりませんかね?
>

以前から ~/.vmware/config には
xkeymap.usekeycodeMapIfXFree86 = true
xkeymap.keycode.211 = 0x073
を設定しています。

Vmware 6.5.x に更新してから vmware の起動が root 出ないと出来なく
なって(対策はあるようですがさほど困らないので放置しています)設定ファ
イルを /etc/vmware/config と /root/.vmware/config
にも追加しましたが解決できません。

x を使用しないときは /etc/vmware/config だけで106 キーボードとして
機能するのでxf86 の kbd に原因があると考えて良いのではないかと思われます。

xorg.conf に何を指定しても us(101) キーボードとして値を入力します。
下記のオプションを組み合わせて指定したのですがどの組み合わせでも変
わりありません。(plamo 4.6 のキーボードドライバ(kbd)は自動判定して
いるのでしょうか。
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbLayout" "jp"
Option "XkbModel" "jp106"
Option "XkbVariant" "jp"
Option "XkbOptions" "jp"
Option "AutoRepeat" "500 30"

また、plamo 4.2 ではこの問題は起きません。
つまり、右上の \| も右下の \_ も入力出来ます。
plamo 4.2 では
Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbLayout" "jp"
EndSection
で jp(106)キーボードとして働きます。
# 同じVMwareで同時に実行しています。

-- 早間

投稿者 xml-rpc : 2009年7月27日 19:31
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/87057
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。