2010年11月 9日

[PHP-users 35399]Windows IIS Violationエラーについて

オカムラと申します。

後述の環境で、Violationエラーが発生して困っています。
PDOが怪しいという事で、Violationエラーが発生した際に、
PDO
PEAR::DB
PEAR::MDB2
それぞれで、簡単なSELECT文を実行したところPDOの場合だけ、

Violationエラーが発生しました。

対策として、
php_pdo〜とつくDLLを入れ替えようと考えているのですが、そもそも
PDOは回収が入っているのでしょうか?
また、単純にDLLだけの入れ替えで問題が発生しないでしょうか?
現在、5.2.6.6を使っており、バージョンを上げなくてはいけないと
思っているのですが、既存のシステムへの影響を考え、まずはPDO
の対応を優先したいとお考えています。

【環境】
 Windows Server 2003 R2 Standard Edition Service Pack 2
 IIS 6.0
 php5isapi.dllでPHPを実行

PHP has encountered an Access Violation at

【現状】
 php_pdo.dll
  ファイルバージョン:5.2.6.6
  サイズ:94,270バイト

【入れ替え】PHP 5.2.14 zipファイルから
php_pdo.dll
 ファイルバージョン:5.2.14.14
 サイズ:94,286バイト

まとめさせてもらうと、方法を問わずViolationエラーを回避したいという
事になるのですが、
1.PDOでViolationエラーが発生しないようにする方法があるのか?
2.PDOのバージョンは上がっているのか?
3.php_pdo〜とつくDLLの入れ替えで動作に支障をきたさないか?
になります。

対処方法として良い方法があれば教えて下さい。
_______________________________________________
PHP-users mailing list PHP-users@xxxxx
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3


投稿者 xml-rpc : 2010年11月 9日 14:57
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100002
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。