2007年12月14日

[PHP-users 33034] Re:PHPのバージョンアップ

まつやま様、
ありがとうございます。

> portsのインストールのとこみれば出ています。
> それぐらい自分で調べましょうよ。
その通りですよね...
本気で見つからず、結局ロシアのfreebsd.orgから古いのを
ダウンロードしたのですが、エラーが出まくってcvsupすら

インストールできませんでした。


モリ様、
ありがとうございます。

> FreeBSDの場合、大抵のオフィシャルな情報には『友の会サイト ;下記』から日本語で
> リンクされています。
何度もこのページに行っていたのにもかかわらず
"ports 階層全体"のリンクに気づいていませんでした。
ありがとうございます。

> 古いため最新のports.tgzと適合しないシステムをお使いになっている場合には、
> cvsupやcvswebを使って適当な時期のportsを取得する事も可能です。
古いports.tgzを拾ってきたらcvsupすらインストールできないという
八方塞状態でした(泣


> 元記事のエラーについては、使ってはいけない道具を使っているからだと思います。
> (Linuxで一次開発されているソフトには、一般的なmakeではなくGNU-makeで拡張
> された記述方法が使われていたり、shの記述がbashが前提のような形式になって
> いたり、など道具を指定するか記述を変える必要のある部分がちょくちょくあり
> ます。portsのmakefileにUSE_GMAKE=YESとなっているソフトを構築する場合には
> ports使う場合には適切な場面で自動的にgmakeが使われているでしょうが、自身で
> 行う場合にはFreeBSDのmakeではなくgmake[導入されてなければ事前導入する
> 必要があります]を使うなどは必要でしょう)
2年位前にインストールして以来、まったくFreeBSDに触っていなかったのですが
PHPのサポート切れということで思い切ってバージョンアップに挑戦したのですが
なかなかports/パッケージだけではうまくいかず、知識もないのに部分部分ソース
からインストールしてこうなってしまったと深く反省しています。


これから最新のportsをダウンロードして挑戦してみます。
初心者の私に色々とご親切にありがとうございました。
_______________________________________________
PHP-users mailing list PHP-users@xxxxx
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3

投稿者 xml-rpc : 2007年12月14日 14:09
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/67613
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。