2002年1月12日

[obu:01233] Re: OpenBlockSS に付属の samba について

はじめまして。
昨年12月にOpenBlockSSを購入したここたと申します。

From: "Buta Neko" <buta_neko@xxxxx>
> 困っているのは,sambaについてです。
> sambaを動作させたいのですが,方法が分かりません(初歩的な質問で申し訳ござ
いません)。
> :
> 悪戦苦闘で,もう1ヶ月になります(涙)。どうかアドバイスをお願いします。

私はOpenBlockSSのHDDイメージ付属のsambaを以下の手順で無理やり動作させまし
た。

% su
 # ln -s /usr/sbin/smbd /usr/bin/smbd
 # ln -s /usr/sbin/nmbd /usr/bin/nmbd
 # mkdir -p /usr/local/samba/lib
 # mkdir -p /usr/local/samba/private
 # mkdir -p /usr/local/samba/var/lock
 # smbpasswd -a (username) (password)
ブラウザでSWATを起動して設定 http://xx.xx.xx.xx:901
 SWATの[動作状況画面]からsmbdとnmbdをstartさせる。

たぶんconfigure時のディレクトリの設定と、OBSSのHDDイメージで
実際におかれているディレクトリが違っているのが原因だと思います。

もし参考になれば幸いです。

----- Original Message -----
From: "Buta Neko" <buta_neko@xxxxx>
To: <obu@xxxxx>
Sent: Saturday, January 12, 2002 6:27 AM
Subject: [obu:01225] OpenBlockSS に付属の samba について


> 昨年暮れ,OpenBlockSSを購入した ぶたネコと申します。
> 「小型でサーバーとして立派に動作する」ということで購入しましたが,実力を引
き出せないでいます。
> 私の技術力不足のせいで,sambaがうまく動作していない状況です。
> 以下に状況を述べますので,アドバイスをいただきたく思います。
>
> 購入後,まずハードディスク(10ギガ)を増設しました。
> fdiskでパーティションを切り,hda1に約9ギガ,hda2にスワップとして約250
メガ割り当てました。
> ファームウェアをバージョンアップし,「uname -a」とすると,下記のように表示
されます。
> Linux LinuxServer.localdomain.co.jp 2.4.10 #1 Thu Nov 15 16:06:24 JST 2001
ppc unknown
>
> ハードディスクのhda1に「sshdimage.011115.tar.gz」を展開しました。展開した
方法は,ホームページに記述されているとおり,次の方法で行いました。
> # tar xvzpf sshdimage.011115.tar.gz -C /mnt/ide0
>
> 困っているのは,sambaについてです。
> sambaを動作させたいのですが,方法が分かりません(初歩的な質問で申し訳ござ
いません)。
> ハードディスクイメージにsambaが入っているようなのでそれを使おうと思ってい
ます。
> 手順は以下のとおりやりました。
> OpenBlockSSをハードディスクから起動し,
> # su - で,rootになる。
> # ps -aux としても,動作している様子はありません。
> # /etc/rc.d/init.d/smb start とすると,次のように表示されます。
> Starting SMB services: smbd nmbd
> しかし,ps -auxとしても,動作している様子がありません。
> そのまま無視して,swatが使えるように次の事を行いました。
> cat /etc/services | grep swat で,以下の行を確認
> swat 901/tcp
>
> # vi /etc/inetd.conf で,以下の行のコメントアウトを取る
> # swat stream tcp nowait.400 root /usr/sbin/tcpd swat
>
> Open BlockSSを再起動。
> # shutdown -r now
>
> 再起動後,Windows機から http://192.168.253.254:901/にアクセスすると,SWAT
が起動します。
> 動作状況(STATUS)を押してステータスを見ると,smbd,nmdbともに「not
running」となっています。
> 「Start smbd」「Start nmdb」ボタンを押しても,ダメです。
> 「Restart smbd」「Restart nmdb」ボタンを押しても,ダメです。
> /etc/smb.confには,まだ手を加えていません。これを修正しないと,sambaが起動
しないのでしょうか?
> 次に,SWATの全体設定(GLOBALS)で,「Commit Changes」をクリックすると,
「failed to open /usr/local/samba/lib/smb.conf for writing 」と表示されま
す。
>
> # find / -name smb.conf とすると,
> /etc/smb.conf と表示されます。
>
> 過去ログも参照させていただきました。00507や,00680からのスレッドを読みまし
たが,OpenBlockSSと違うのか,よく分かりませんでした。
>
> 悪戦苦闘で,もう1ヶ月になります(涙)。どうかアドバイスをお願いします。
>
>

投稿者 xml-rpc : 2002年1月12日 13:27
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/7236
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。