2009年2月25日

[Namazu-devel-ja 1774] Re:Namazu 2.0.19 pre1 公開

In message <49A40B8C.A875F4DD@xxxxx>
on Wed, 25 Feb 2009 00:00:28 +0900,
Tadamasa Teranishi <yw3t-trns@xxxxx> wrote:
> > > の結果と
> > % wvWare --version
> > wvWare 1.2.5
>
> http://sourceforge.net/project/showfiles.php?group_id=10501

>
> だと 1.2.4 が最新のようですが、1.2.5 はどこ由来なんでしょうね。
一応モノは、

http://www.abiword.com/downloads/wv/1.2.5/

にあります。xlhtml-0.5.1程、怪しくはないと思います。ちなみに pkgsrc の
方での1.2.5になったときのコミット・ログは、

description:
----------------------------
revision 1.64
date: 2008/04/14 23:49:43; author: wiz; state: Exp; lines: +3 -4
Update to 1.2.5, changes unknown.
----------------------------

と、いうことで、変更内容自体は宛になりません。:-(

> $ wvWare --charset=EUC-JP tests/data/ja/word6.doc > word6.html
>
> で出力した word6.html はどんな感じになっていますかね?

----------------------------------------------------------------

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=EUC-JP">
<META NAME="GENERATOR" CONTENT="wvWare/wvWare version 1.2.5">
<title>
〓〓〓〓〓
</title>
</head>
<body bgcolor="#FFFFFF" text="#000000" link="#0000ee" vlink="#551a8b">

<!--Section Begins--><br>

<p><div name="〓W〓〓" align="left" style=" padding: 0.00mm 0.00mm 0.00mm 0.00mm; ">

<p style="text-indent: 0.00mm; text-align: left; line-height: 4.166667mm; color: Black; background-color: White; ">

</p></div>

<p><div name="〓W〓〓" align="left" style=" padding: 0.00mm 0.00mm 0.00mm 0.00mm; ">
(以下略)
----------------------------------------------------------------

てな感じです。

> パッケージではなくソースから素の wvWare 1.2.5 をインストールしても
> 同様なら、wvWare 1.2.5 は Word7 未対応ということになりますので、
おそらく、pkgsrcでインストールされたライブラリに依存させる他は特別なパッ
チは当たっていないので、素でインストールしても変わらない気がします。

ただ、

% ldd /usr/pkg/bin/wvWare
/usr/pkg/bin/wvWare:
-lc.12 => /usr/lib/libc.so.12
-lz.1 => /usr/lib/libz.so.1
-lm.0 => /usr/lib/libm.so.0
-lxml2.2 => /usr/pkg/lib/libxml2.so.2
-lbz2.1 => /usr/lib/libbz2.so.1
-lpcre.0 => /usr/pkg/lib/libpcre.so.0
-lintl.1 => /usr/lib/libintl.so.1
-lglib-2.0.0 => /usr/pkg/lib/libglib-2.0.so.0
-lgobject-2.0.0 => /usr/pkg/lib/libgobject-2.0.so.0
-lgmodule-2.0.0 => /usr/pkg/lib/libgmodule-2.0.so.0
-lgio-2.0.0 => /usr/pkg/lib/libgio-2.0.so.0
-lgsf-1.114 => /usr/pkg/lib/libgsf-1.so.114
-lwmflite-0.2.7 => /usr/pkg/lib/libwmflite-0.2.so.7
-lfreetype.6 => /usr/pkg/lib/libfreetype.so.6
-lXau.6 => /usr/pkg/lib/libXau.so.6
-lXdmcp.6 => /usr/pkg/lib/libXdmcp.so.6
-lX11.6 => /usr/pkg/lib/libX11.so.6
-lexpat.1 => /usr/pkg/lib/libexpat.so.1
-ljpeg.62 => /usr/pkg/lib/libjpeg.so.62
-lpng12.0 => /usr/pkg/lib/libpng12.so.0
-lwmf-0.2.7 => /usr/pkg/lib/libwmf-0.2.so.7
-lwv-1.2.4 => /usr/pkg/lib/libwv-1.2.so.4

といった具合いなので、後は GNU iconv でないことくらいでしょう。
(時間があれば、こちらも追試します。)

> が、現状ではパッケージの問題か、wvWare 側の問題か不明です。
> どなたか、他の環境で wvWare 1.2.5 を使われている方はいませんかね?
一応、diff取ってみました。:-)

ftp://ftp.back-street.net/pub/tmp/diff-wv-1.2.4-1.2.5.gz
> > > $ pdftotext -enc EUC-JP tests/data/ja/acrobat4.pdf -
> > % pdftotext -enc EUC-JP tests/data/ja/acrobat4.pdf -
> > Error: Couldn't find unicodeMap file for the 'EUC-JP' encoding
> > Error: Couldn't get text encoding
> >
> > こちらはpkgsrcのxpdf-3.02pl2とxpdf-japanese-20040727にをインストールし
> > た状態です。
>
> パッケージに問題ありですね。
> # 過去にはFreeBSD のパッケージにも問題があったけど
こちらはわかりました、確かにパッケージに問題ありです。

簡単に言えば、ソースからパッケージをインストールした場合は良いのです
が、バイナリ・パッケージでインストールするとダメダメです。:-(

--
神戸 隆博 / Takahiro Kambe

_______________________________________________
Namazu-devel-ja mailing list
Namazu-devel-ja@xxxxx
http://www.namazu.org/cgi-bin/mailman/listinfo/namazu-devel-ja


投稿者 xml-rpc : 2009年2月25日 00:30
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/82453
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。