2006年9月21日

[Namazu-devel-ja 1234] Re: ptknamazu

臼田です

NOKUBI Takatsugu wrote:
> どんなバージョンのActivePerlを用意すればいいでしょうか。環境をあわせ
> て試してみようと思います。あと、Namazu for Windows自体も必要でしょうか。
>
Perl/Tk のマルチバイト対応度から ActivePerl はできるだけ新しい版
にしておく必要があります。Perl/Tk は ActivePerl をインストールすれば

いっしょにインストールされます。
私の今の環境は Perl 5.8.8 build817 、 Tk.pm 804.027 です。

Search-Namazu を使った最小限の機能の検索クライアントなので
Namazu をインストールしてインデックスを作成済み
になっていることが前提です。単体では使えません。
MS-Windows 環境であれば Namazu for Windows と ActivePerl 用
Search-Namazu の最新版を寺西さんのサイトからインストール
しておく必要があります。

特殊なことはしていないので UNIX の通常の Perl でも Perl/Tk
と Search-Namazu をインストールすれば動作するはずです。

>> ・設定を保存できない(どこに保存するのがよさそうでしょうか)
>>
>
> Windowsならアプリケーションのある場所に.iniがあるとうれしそうです。
> Unix系なら$HOME以下にドットファイルとして作成するのが王道でしょう。
>
WindowsアプリケーションというわけではないのでUnix系のスタイルでしょうね

>> ところで Search-Namazu には Namazu のバージョンを取
>> 得する関数はないのでしょうか。
>>
>
> 最初にSearch-Namazuを作った時にはlibnmz自体にバージョン取得を行う関
> 数がなかったので、付けていません。
> configureにバージョン取得関数の存在チェックを追加した上で実装してみ
> ましょうか。
>
バージョン取得ができないと困ることがあるように思えます。
よろしくお願いします。

臼田幸生
_______________________________________________
Namazu-devel-ja mailing list
Namazu-devel-ja@xxxxx
http://www.namazu.org/cgi-bin/mailman/listinfo/namazu-devel-ja

投稿者 xml-rpc : 2006年9月21日 12:33
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/46389
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。