2006年8月29日

[Namazu-devel-ja 1187] NKF 2.0.6 以降を対象とするように修正しました

寺西です。

pl/codeconv.pl に以下のような修正を加えました。(HEAD)

- NKF 2.0.6 以降を対象としました。
NKF については、UTF-8 対応である NKF 2.0 以降が必要ですが、2.0.5
までは変換の際にゴミが混ざるバグがあります。
また、-W16L, -W16B オプションが指定できることもあり 2.0.6 以降を

対象としました。
同時に UTF-16 BOM が必要ではなくなりました。
- from_to で指定するキャラセット名を nkf のオプションに対応する
エリアスを追加しました。
- コード変換は言語処理以外のメッセージの処理においても使用する可能性
があるので、いくつかは util::islang_msg("ja") が真の場合にも
通るようにしました。
ただし、まだ整理できていないので、対応は不十分かもしれません。
- Text::Iconv への対応の準備をしました。
昨今、Encode のマッピングがかなり特殊なものであることがわかりまし
たので、Text::Iconv への対応が必要と考えを改めました。

課題
- nkf コマンドのバージョンチェックを行う必要がありますが、対応できて
いません。
- Text::Iconv への対応が必要です。
--
=====================================================================
寺西 忠勝(TADAMASA TERANISHI) yw3t-trns@xxxxx
http://www.asahi-net.or.jp/~yw3t-trns/index.htm
Key fingerprint = 474E 4D93 8E97 11F6 662D 8A42 17F5 52F4 10E7 D14E

_______________________________________________
Namazu-devel-ja mailing list
Namazu-devel-ja@xxxxx
http://www.namazu.org/cgi-bin/mailman/listinfo/namazu-devel-ja

投稿者 xml-rpc : 2006年8月29日 02:02
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/45033
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。