2012年7月13日

[mysql 15806] Re: PHPとutf8mb4

yokuです。

libmysqlclient.so.xxはシンボリックリンクでlibmysqlclient.so.xx.0.0にリンクされているので、
libmysqlclient.so.15のリンク先をlibmysqlclient.so.18.0.0に振ってやると動くかも知れません。
(少なくとも接続だけは出来ます。Perlですが)

あまり推奨できるやり方ではありませんが、情報まで。。


ts. yoku//

2012年7月12日 20:49 <a2cf@xxxxx>:
> 藤田です。
>
>> php-mysqlでインストールされている.soファイルに対して
>> lddコマンドを試すと、どのモジュールを実際に使っているのかが見えます。
>
> 確認したところ、以下のようにlibmysqlclient.so.15へリンクされているようでした・・・。
>
> $ rpm -ql php53-mysql
> /etc/php.d/mysql.ini
> /etc/php.d/mysqli.ini
> /etc/php.d/pdo_mysql.ini
> /usr/lib/php/modules/mysql.so
> /usr/lib/php/modules/mysqli.so
> /usr/lib/php/modules/pdo_mysql.so
>
> $ ldd /usr/lib/php/modules/mysqli.so
> ...
> libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0x00b6f000)
> ...
>
> やはりこれは素直にPHPをコンパイルし直すしかなさそうですね・・・。
> 一度それもテストしてみようかと思います。
>
>
> 何とぞよろしくお願いいたします。
>
>
>
>


投稿者 xml-rpc : 2012年7月13日 11:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/111262
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。