2012年3月28日

[mew-dist 29493] Re: Mew 6.5rc1

あらいです。

> stunnel が知らないオプションに対して寛容か、このオプションは実際に有効
> なのか、調べてもらえると嬉しいです。

 書き忘れましたが、先のパッチとstunnel 4.46の組み合わせでは動作実績が
あります。

 手元にstunne 4.38(libwrapをリンクしたもの)があったので、libwrapオプ
ションに加えてデタラメなオプション指定をしたMew 6.5rc1を用意して試して
みました。

stunnel 4.38 / 4.46
変なオプション あり / なし

 で、ちゃんと動いたのは 4.46-なし の組み合わせだけでした。
 stunnelのChangeLogのここの部分

Version 4.45, 2011.10.24, urgency: LOW:
...
- Libwrap helper processes are no longer started if libwrap is disabled
in all sections of the configuration file.

から推察するに、[mew-dist 29487]のパッチはこのようにした方がいいかも知
れません。一応、このmew-ssl.elとstunnel 4.46では問題ないようです。

--- mew-ssl.el 2012-03-28 21:01:36+09 1.1
+++ mew-ssl.el 2012-03-28 21:23:38+09
@@ -102,6 +102,8 @@
(insert (format "verify=%d\n" (mew-ssl-verify-level case)))
(insert "foreground=yes\n")
(insert "debug=debug\n")
+ (if (>= mew-ssl-minor-ver 45)
+ (insert "libwrap=no\n"))
(if (>= mew-ssl-minor-ver 22)
(insert "syslog=no\n"))
(insert "CApath=" (expand-file-name (mew-ssl-cert-directory case)) "\n")


投稿者 xml-rpc : 2012年3月28日 21:30
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/109175
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。