2012年3月14日

[mew-dist 29460] Re: SSL SMTP for gmail

たかのです。こんにちは。

From: Ryo Furue <furue@xxxxx>さん
> GmailをSMTPサーバとして使わざるを得なくなり、設定が上手くいかず苦労し
> ています。グーグルで調べても、似たような症状は見つけられませんでした。
> stunnel がそもそも使えているかどうかを調べる方法も中々見つかりません。
> (探し方が悪いのかも知れませんが . . .)
> どなたかヒントを下されば幸いです。


以下、僕がその昔書いたエントリですが、参考になりますか?

http://www.running-dog.net/2009/01/mew_ssl_stunnel_etchostsallow.html

まず、 stunnel が libwrap をリンクしているか確認します。下記の
症状では多分 libwrap がリンクされているような気がするのですが。

もしリンクされている stunnel であれば configure オプションで
--disable-libwrap を付加して make しなおすのが良いかと思われます。


次にもう一点。libwrap がリンクされていない場合の確認方法ですが、
mew から stunnel を利用すると /tmp 配下に mew がファイルを生成し
ています。ps -axwww | grep stunnel すればそのファイル名が確認で
きると思いますが、そのファイルの connect= が正しいか確認した後に、
以下の行

accept=127.0.0.1:11788

に対して telnet で確認してみれば google のサーバに到達できてい
るか確認できると思います。


> [症状]
> 1. emacs を起動
> 2. C-x m でメールを作成し、C-c C-c で送信。
> 3. ミニバッファーに、"Creating an SSL/TSL connection . . ." と出たまま
> emacs がフリーズする。
> 4. C-g で中断。しばらく待つが、宛先にはメールは届いていない。
> 5. M-x mew で mew を起動し、+queue へ移動。先程作成したメッセージがあ
> る。
> 6. そのメッセージを C-c C-c で送信しようとする。
> 7. ミニバッファーに "SMTP PLAIN password (ユーザー名@hawaii.edu):"
> というプロンプトが出るので、パスワードを打ち込む。
> 8. ミニバッファーに "Sending in background...done" というメッセージが
> 出る。宛先には早速メールが届いている。
>
> 上記の3の段階で、"ps -ef" を見ると /usr/bin/stunnel4 が沢山起動されて
> います。
>
> [設定ファイル]

設定は多分大丈夫だと思います。libwrap 無し stunnel の場合で到
達出来なかったら何かしらの問題があるのでしょうねぇ・・f(^^;;。

> [環境]
> Debian GNU/Linux (testing)
> mew 1:6.3-3
> stunnel4 3:4.52-1
> (Debian 特有のバージョン番号かも知れません。)

とりあえず stunnel コマンドを ldd してみることだと思います。

たかの
---
Contact to me.
takachan[at]running-dog.net http://www.running-dog.net/
takachan[at]icmpv6.org http://icmpv6.org/


投稿者 xml-rpc : 2012年3月14日 11:55
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/108802
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。