2011年3月21日

[mew-dist 29364] Re:POP/SMTP over SSLでのメールの送受信ができない

渡部と申します。
お返事が遅くなりまして,ごめんなさい。

On 2011/03/08, at 23:51, TAKANO Yuji (たかのゆ?じ) wrote:

>> *クライアント環境
>> Mac OS X 10.6.6 / GNU Emacs 24.0.50 / Mew 6.3.50
>

> 上記の環境で、mew からの SSL はどうやっているのでしょうか?
> stunnel を利用しているのでしょうか?他に mew で SSL のトンネルの
> 抜け方を僕は知らないのですが・・。

http://www.stunnel.org/ より,ソース(Stunnel-<Version>.tar,gz) を
ダウンロードして,

$ ./configure
$ make
$ sudo make install

で,インストールしています。

> 以下の URL は参考になりますか?
>
> http://www.running-dog.net/2009/01/mew_ssl_stunnel_etchostsallow.html
>
> と、言うのも stunnel は libwrap を link していると mew から利
> 用できません。 stunnel の configure 時に --disable-libwrap した
> ものを利用する必要があります。

Mac OS X 10.6.6ですが,以前の環境(IIJmio セーフティメール)では,
そのようなオプションをつけて,configure しなくとも使えていました。

しかし,おっしゃるとおりにちょっと試してみます。

> MacOSX であれば otool -L stunnel で確認してみてはどうでしょう?
>
> stunnel はソースから make したのか、何かしらのパッケージシステ
> ムからインストールしたのかちょっと解りませんが上記コマンドでまず
> は stunnel を調べてみてはと思います。

$ otool -L stunnel
stunnel:
/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.1)
/usr/lib/libutil.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
/usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
/usr/lib/libwrap.7.dylib (compatibility version 7.0.0, current version 7.6.0)

という返ってきます。どうなのでしょうか。

---
WATANABE, Takeo
take@xxxxx


投稿者 xml-rpc : 2011年3月21日 09:52
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/102675
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。