2010年5月13日

[mew-dist 29227] Re: zip

細川です

|Date: Thu, 13 May 2010 18:11:12 +0900
|From: Yu-ji Hosokawa <yu-ji@xxxxx>
|Message-Id: <20100513.181112.452535131.orz@xxxxx>
|Subject: Re: [mew-dist 29222] Re: zip
> また、Debian GNU/Linux lenny の zip 2.32 では
> まだ -P オプションが無いっぽいです。

>
> $ zip
> Copyright (c) 1990-2006 Info-ZIP - Type 'zip "-L"' for software license.
> Zip 2.32 (June 19th 2006). Usage:
> (略)

すみません、確認が足らなかったです。

ソースの CHANGES によると zip 2.2i から追加されたようなのですが、
2.32 の時点では

$ zip -e -P hoge hoge.zip hoge.txt

では Enter password / Verify password のプロンプトが表示され、
パスワード入力の後に

zip error: Invalid command arguments (can only have one -P)

というエラーになります。


このバージョンでは

$ zip -P hoge -e hoge.zip hoge.txt

あるいは

$ zip -P hoge hoge.zip hoge.txt

でいけるようです。

CHANGES によると 3.0f03 から -P と -e の扱いが変わったような雰囲気です…。

--
Yu-ji Hosokawa (細川雄司)


投稿者 xml-rpc : 2010年5月13日 20:03
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/95730
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。