2012年5月24日

[linux-users: 108888] Re:grub が kernel を認識しない

竹中@長岡京市です。

超遅いレスになり申し訳ございません。
いろいろ調べたところ、インストール時にマウントしていた boot パーティッ
ションが、
マウントされていない事が原因でした。
つまり、

/dev/sda1・・・boot パーティッション
/dev/sda2・・・swap パーティッション
/dev/sda3・・・/ パーティッション

で、/ の直下に、/boot ディレクトリを作り、インストール時はそこに boot
パーティッション
をマウントしていました。fstab には、/dev/sda1 のマウントポイントとして、
/boot を指定
したので、マウントされているものだと思い込み、ここにカーネルをコピーして
いました。
しかし、実際には grub は、 boot パーティッションとして、/dev/sda1 を見に
行くので、
そこに新しいカーネルがなかったということです。(新しいカーネルは、/dev
/sda3 の /boot
にありました。)

PPC Linux 歴は長いのですが、PC Linux は始めたばかりです。PC Linux では、
パーティッション
作成時に、boot パーティッションとして指定すると、fstab マウントポイント
を指定していても
マウントされないものなのでしょうか?

まだまだ、PC Linux はわからない事だらけです。今後ともよろしくお願いします。

(2012年05月12日 22:31), Takeshi Kusune wrote:
> 楠根です。
>
> (2012/05/12 22:11), Hiroshi Takenaka wrote:
>> kernel を再構築して 、/boot ディレクトリにコピーして新カーネルでの起動を
>> 試みているのですが、grub がカーネルを認識してくれません。
>> grub.conf は以下のようになっています。
>> ---------------------------------------------------
>> title Gentoo Linux 3.2.12 frame buffer
>> root (hd0,0)
>> kernel /boot/kernel-3.2.12-gentoo-fb root=/dev/sda3
>>
>> title Gentoo Linux 3.2.12 no frame buffer
>> root (hd0,0)
>> kernel /boot/kernel-3.2.12-gentoo root=/dev/sda3
>> clock=pit nosmp noapic nolapic
>> マシン起動後、"Linux 3.2.12 frame buffer"を選択すると、
>>
>> Error 15
>> File not found
>>
>> でエラーになります。"Linux 3.2.12 no frame buffer"を選択すると正常に立ち
>> 上がります。
> /boot は後から別 partition を割り当てて mount したとかじゃないですか?
> 古い kernel が入ってるのも grub.conf で参照してるのも (hd0,0)/boot ですが、
> 新しい kernel は後から /boot になったどこか別の partition の / 以下、みたいな。
>
> 元々入ってた kernel が /dev/sda1 の /boot に入ったまま、
> /boot に上から別の partition を mount してしまい、
> システム的には /boot に見えるその partition の / に新しい kernel があるのでしょう。
>
>> パーティッション構成は、
>>
>> /dev/sda1 /boot -> ext2
>> /dev/sda2 swap
>> /dev/sda3 /root -> ext3
>>
>> となっております。
> この情報が正しいとすると推測は外れですが、
> この情報だと grub.conf によれば / のはずの /dev/sda1 が /boot になってます。
> 手書きの段階で写し間違えたのではないですか?
> mount コマンドの結果か /proc/mounts の中身をそのまま貼るべきです。
>
>> Gentoo 独特(特に kernel-3.2)の問題なのか、VMware 独特の問題なのか、
>> 全く切り分けできておりません。かなり、グーグッてみたのですが同様の問題は
>> 発見できませんでした。
> 恐らく後からいじった filesystem 構成と設定のミスマッチです。
> システムの不具合とかではなくオペレーションの問題ですね。
> --
> Takeshi Kusune <kusune@xxxxx>
> _______________________________________________
> linux-users mailing list
> linux-users@xxxxx
> http://listserv.linux.or.jp/mailman/listinfo/linux-users
>


--
*************************
Hiroshi TAKENAKA
Nagaokakyo, Kyoto, Japan
*************************

_______________________________________________
linux-users mailing list
linux-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/linux-users


投稿者 xml-rpc : 2012年5月24日 21:49
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110558
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。