2011年7月24日

[linux-users: 108824] Re:Linux 3.0 の patch

こんにちは。松田陽一@三鷹です。

From: Tomoaki Yamada <yamadato@xxxxx>
Subject: [linux-users: 108823] Re: Linux 3.0 の patch
Date: Sat, 23 Jul 2011 23:58:04 +0900

> 山田と申します。
>

> 2.6.39にはDocumentation/lguest ディレクトリが存在しますが、
> 3.0には存在しません。
>
> 私はmake-kpkgを知りませんので分かりませんが、一度ソースディ
> レクトリをクリーンな状態にしてから作業をし直されてはいかが
> でしょうか?

いえ、ソースディレクトリは本当にクリーンな状態から、 make-kpkg を使用
しました。

> 私は
> $ make menuconfig
> $ make bzImage
> で問題なくビルドが完了し3.0.0で稼働しています。

debian squeeze の make-kpkg が 3.0.0 に対応していないのでしょう。
そのうち何らかの情報が出るでしょうから、私はそれまで待つことにします。

>
> ---
> Tomoaki Yamada
>
>
> (2011/07/23 23:17), MATSUDA Yoh-ichi / 松田陽一 wrote:
>> こんにちは。松田陽一@三鷹です。
>>
>> From: Tomoaki Yamada<yamadato@xxxxx>
>> Subject: [linux-users: 108821] Re: Linux 3.0 の patch
>> Date: Sat, 23 Jul 2011 21:06:54 +0900
>>
>>> 山田と申します。
>>>
>>> 私はpatch-kernelスクリプトを使ったことがないので分かりませんが。
>>> 手元で試したところ、2.6.39へのパッチで間違いないようです。
>>>
>>> $ work/src/linux-2.6.39$ bzip2 -cd ../patch-3.0.bz2 | patch -p1
>>>
>>> で問題なくパッチの適用が完了しました。
>>
>> 有難うございます、御指示のコマンドラインで正常に patch 適用できました。
>>
>> _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._.
>> ところが、 make-kpkg したら、以下のエラーを吐いて止まってしまいました。
>>
>> IHEX2FW firmware/whiteheat.fw
>> IHEX2FW firmware/keyspan_pda/keyspan_pda.fw
>> IHEX2FW firmware/keyspan_pda/xircom_pgs.fw
>> IHEX firmware/cpia2/stv0672_vp4.bin
>> make[1]: Leaving directory `/home/yoh/work/linux-2.6/linux-3.0.0'
>> /usr/bin/make ARCH=i386 \
>> -C Documentation/lguest
>> make: *** Documentation/lguest: No such file or directory. Stop.
>> make: *** [debian/stamp/build/kernel] Error 2
>>
>>
>>> ---
>>> Tomoaki Yamada
>>>
>>> (2011/07/23 15:52), MATSUDA Yoh-ichi / 松田陽一 wrote:
>>>> こんにちは。松田陽一@三鷹です。
>>>>
>>>> Linux 3.0 がリリースされた、とのことで
>>>> http://slashdot.jp/linux/article.pl?sid=11/05/31/0446241
>>>>
>>>> いつものようにカーネルの patch を入手して patch-kernel したところ、
>>>>
>>>> hoge:~/work/linux-2.6$ ./linux-2.6.39/scripts/patch-kernel ./linux-2.6.39 . 3.0
>>>> Current kernel version is 2.6.39 ( Flesh-Eating Bats with Fangs)
>>>> ./linux-2.6.39/scripts/patch-kernel: line 225: [: -lt: unary operator expected
>>>> ./linux-2.6.39/scripts/patch-kernel: line 248: [: -gt: unary operator expected
>>>> hoge:~/work/linux-2.6$
>>>>
>>>> このようなエラーを吐かれてしまい、進めません。
>>>>
>>>> 2.6.39 から 3.0 への patch-kernel は使えないのでしょうか。
>>>> だとすると、 patch-3.0.bz2 は何に対する patch なのでしょうか。

--
松田 陽一(yoh)
mailto:yoh@xxxxx
http://www.flcl.org/~yoh/diary/
http://twitter.com/Yoh_Matsuda
_______________________________________________
linux-users mailing list
linux-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/linux-users


投稿者 xml-rpc : 2011年7月24日 12:07
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105177
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。