2010年12月 1日

[linux-users: 108686] Re:openssl(apache)のバージョンアップについて

こんばんわ。

山本です。

お世話なっております。

比較を行ったサーバは、
さくら専用でCentOSの標準構成同士の比較だったんですが。。。

なんか私が触ってたんでしょうかね。。。

色々ありがとうございます。
もう少し助言を合わせて格闘して頑張ってみます。

また何かあればご教授頂けると幸いです。

石川 様
橋本 様

お返事ありがとうございました。

> 石川といいます。
>
> 2010/11/29 山本 <yamamoto.n@xxxxx>:
> 略
> > libssl.so.6 => /lib/libssl.so.6が出ません。。。
> > 他のサーバは、
> > libssl.so.6 => /lib/libssl.so.6 (0x00354000)
> > が出ました。
>
> 出ない方は静的リンクされている。
> でもってapacheのパッケージもちょっと違う、に一票。
> #業務で使っているサーバだったら、どっちかに(できればCent標準に)揃えるのが
> #ベターな気はします。ほんとに違ってたらですが。
>
> では。
>
> 2010/11/29 山本 <yamamoto.n@xxxxx>:
> > 山本です。
> >
> > お世話になっております。
> > お忙しい所、返信ありがとうざいます。
> >
> > おかしな事?が起こったのでまた助言を頂きたいです。
> >
> >
> > # ldd /usr/sbin/httpd
> >
> > linux-gate.so.1 => (0x00588000)
> > libm.so.6 => /lib/libm.so.6 (0x004ca000)
> > libpcre.so.0 => /lib/libpcre.so.0 (0x00324000)
> > libselinux.so.1 => /lib/libselinux.so.1 (0x00b1c000)
> > libaprutil-1.so.0 => /usr/lib/libaprutil-1.so.0 (0x00bdb000)
> > libcrypt.so.1 => /lib/libcrypt.so.1 (0x00409000)
> > libexpat.so.0 => /lib/libexpat.so.0 (0x00110000)
> > libdb-4.3.so => /usr/lib/libdb-4.3.so (0x00131000)
> > libapr-1.so.0 => /usr/lib/libapr-1.so.0 (0x00ccb000)
> > libpthread.so.0 => /lib/libpthread.so.0 (0x00229000)
> > libdl.so.2 => /lib/libdl.so.2 (0x00242000)
> > libc.so.6 => /lib/libc.so.6 (0x00589000)
> > /lib/ld-linux.so.2 (0x006f7000)
> > libsepol.so.1 => /lib/libsepol.so.1 (0x00247000)
> > libuuid.so.1 => /lib/libuuid.so.1 (0x009c6000)
> >
> >
> > ・・・・
> >
> > libssl.so.6 => /lib/libssl.so.6が出ません。。。
> >
> > 他のサーバは、
> >
> > libssl.so.6 => /lib/libssl.so.6 (0x00354000)
> >
> > が出ました。
> >
> > 肝心の
> > libssl.so.6 => /lib/libssl.so.6が出ない方は、
> > 特に問題なくグローバルサインのSSL動作しております。
> >
> > 何がおかしいのかなっと・・・
> >
> > # ll /usr/lib/libssl*
> >
> > -rw-r--r-- 1 root root 432020 Nov 22 16:03 /usr/lib/libssl.a
> > lrwxrwxrwx 1 root root 15 Nov 22 16:03 /usr/lib/libssl.so -> libssl.so.0.9.8
> > -r-xr-xr-x 1 root root 309510 Nov 22 16:03 /usr/lib/libssl.so.0.9.8
> > lrwxrwxrwx 1 root root 24 Nov 22 16:03 /usr/lib/libssl.so.6 -> /usr/lib/libssl.so.0.9.8
> > -rwxr-xr-x 1 root root 217560 Oct 20 20:09 /usr/lib/libssl3.so
> >
> > # ll /lib/libssl.so.6
> > /lib/libssl.so.6 -> libssl.so.0.9.8e
> >
> > # ls -l /lib/libssl.so.6
> > lrwxrwxrwx 1 root root 16 May 16 2010 /lib/libssl.so.6 -> libssl.so.0.9.8e
> >
> > ↓が古くて
> > # ls -l /usr/lib/libssl.so.0.9.8
> > -r-xr-xr-x 1 root root 309510 Nov 22 16:03 /usr/lib/libssl.so.0.9.8
> >
> > ↓新しい
> > # ls -l /usr/local/ssl/lib/libssl.so.0.9.8
> > -r-xr-xr-x 1 root root 289360 Oct 23 2009 /usr/local/ssl/lib/libssl.so.0.9.8
> >
> >
> >
> > なので、
> > 単純に
> >
> > ln -s /usr/lib/libssl.so.0.9.8 /lib/libssl.so.6
> >
> > で解決なのですかね。。。
> >
> > ごちゃごちゃし過ぎて分からなく。。。
> >
> > よろしくお願い致します。
> >
> >
> >> 石川といいます。
> >>
> >> 2010/11/26 Shinobu Hashimoto <snbhsmt@xxxxx>:
> >> > 2010年11月26日10:07 山本 <yamamoto.n@xxxxx>:
> >> >> なので、apacheが/usr/local/ssl/lib/libcrypto.aを読み込みに行ってると思わ
> >> >> れるのですが、これを/usr/lib/libcrypto.aにする方法で、
> >> >
> >> > よく分からないのですが、*.a は静的リンクされるものではないでしょうか。
> >> > httpd が libcrypto.so を動的リンクする様になっていないという事だったら、
> >> > httpd をリコンパイルする必要がある様な気がします。
> >>
> >> *.a は静的リンクですね。なので、リンクする *.a を変えたいということならば
> >> httpd をリコンパイルするしかないですね。
> >>
> >> でも、今時ライブラリを動的リンクしないものはあまりないと思うので。。。
> >> > httpd はどの libssl.so をリンクするのでしょうか。
> >> これですね。
> >> OpenSSLのldd調べたのなら、httpdのlddも調べないと。
> >> これが何をリンクしているか。
> >> でもって、
> >> > libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0x002e3000)
> >> みたいな行がたぶんあるので、新しくインストールしたOpenSSLのライブラリを
> >> 見に行くようにリンクを張り直せば取りあえずは希望通りの動作はすると
> >> 思います。
> >>
> >> では。
> >>
> >> 2010/11/26 Shinobu Hashimoto <snbhsmt@xxxxx>:
> >> > 橋本と申します。
> >> >
> >> > 2010年11月26日10:07 山本 <yamamoto.n@xxxxx>:
> >> >> # ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.6
> >> > (snip)
> >> >> # ls -l /lib/libssl.so.6
> >> >> lrwxrwxrwx 1 root root 16 May 16 2010 /lib/libssl.so.6 -> libssl.so.0.9.8e
> >> >
> >> > httpd はどの libssl.so をリンクするのでしょうか。
> >> >
> >> >> なので、apacheが/usr/local/ssl/lib/libcrypto.aを読み込みに行ってると思わ
> >> >> れるのですが、これを/usr/lib/libcrypto.aにする方法で、
> >> >
> >> > よく分からないのですが、*.a は静的リンクされるものではないでしょうか。
> >> > httpd が libcrypto.so を動的リンクする様になっていないという事だったら、
> >> > httpd をリコンパイルする必要がある様な気がします。
> >> >
> >> > --
> >> > Shinobu Hashimoto (snbhsmt@xxxxx)
> >> > _______________________________________________
> >> > linux-users mailing list
> >> > linux-users@xxxxx
> >> > http://listserv.linux.or.jp/mailman/listinfo/linux-users
> >> >
> >>
> >>
> >>
> >> --
> >> -- nobichan
> >> _______________________________________________
> >> linux-users mailing list
> >> linux-users@xxxxx
> >> http://listserv.linux.or.jp/mailman/listinfo/linux-users
> >
> > _______________________________________________
> > linux-users mailing list
> > linux-users@xxxxx
> > http://listserv.linux.or.jp/mailman/listinfo/linux-users
> >
>
>
>
> --
> -- nobichan
> _______________________________________________
> linux-users mailing list
> linux-users@xxxxx
> http://listserv.linux.or.jp/mailman/listinfo/linux-users

_______________________________________________
linux-users mailing list
linux-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/linux-users


投稿者 xml-rpc : 2010年12月 1日 20:08
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100405
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。