2010年6月28日

[linux-users: 108486] Re: Redhat Clis terSuite

川崎様

ちなみに、設定はluci/icciではなく
system-config-cluster
で設定しました。

さっきの返信の補足でした。


--- kawasaki@xxxxx wrote:

> こんにちは。
>
> qdiskd が動作していない場合、qdisk からの vote
> を得ることが
> できないため、qdiskを使用しようとする、期待通りの動作
にならないと思います。
> (cman_tool status の結果はいかがでしょう?)
>
> また、qdisk の設定は luci/ricci から行われましたか?
> 可能なら、cluster.conf の<quorumd ...>
> 部分だけ拝見できると
> うれしいのですが。
>
> 通常、qdisk は全ノードで chkconfig qdiskd on して
> おきサービスを開始するだけで大丈夫なはずですが、
> mkqdisk -d -L で
> デバッグ情報を出力して、以下のような結果になるかをご確
認下さい。
>
> mkqdisk v0.6.0
> /dev/disk/by-id/<略>
> /dev/disk/by-path/<略>:
> /dev/sda2:
> Magic: eb7a62c2
> Label: myqdisk
> Created: Fri Jan 8 11:03:01 2010
> Host: node1.cluster8.example.com
> Kernel Sector Size: 512
> Recorded Sector Size: 512
>
> Status block for node 1
> Last updated by node 1
> Last updated on Wed Jan 13 18:38:23 2010
> State: Master
> Flags: 0000
> Score: 0/0
> Average Cycle speed: 0.000000 seconds
> Last Cycle speed: 0.000000 seconds
> Incarnation: 4b4d7d2f4b4d7d2f
> Status block for node 2
> Last updated by node 2
> Last updated on Wed Jan 13 18:38:22 2010
> State: Running
> Flags: 0000
> Score: 0/0
> Average Cycle speed: 0.000166 seconds
> Last Cycle speed: 0.000000 seconds
> Incarnation: 4b4d7db24b4d7db2
>
> (略)
> --
> 川崎
>
>
> 引用 bbb uss <bbbuss_7@xxxxx>:
>
> > 川崎様
> >
> > アドバイスありがとうございます。
> >
> >
> 実は今手元に環境がないので結果を提示することができませ

> > ので可能であれば、service qdiskd
> statusの結果がrunningの
> >
> 場合とrunningでなかった場合の対処などご教授いただけま

> > と本当に助かります。なお、補足ですがqdisk
> startのあとに
> >
> ログを確認したところsuccessの文字がありませんでした。
> >
> >
> 恐れ入りますが、ご教授のほどよろしくお願いいたします。
> >
> >
> > --- kawasaki@xxxxx wrote:
> >
> >> こんにちは。川崎と申します。
> >>
> >>
> そのメッセージはちゃんと動いていないようにみえますが、
> >> mkqdiskは成功していると仮定して、全ノードで
> >> service qdiskd status
> >> の結果はいかがでしょうか?
> >>
> >> また、/var/log/messages に
> >> 起動失敗のログなどは残ってないでしょうか?
> >>
> >> --
> >> kawasaki at wwing.net
> >>
> >> 引用 bbb uss <bbbuss_7@xxxxx>:
> >>
> >> > 【環境】
> >> > ・OS:RHEL5.4
> >> > ・Server:HpDL380×2台
> >> > ・Storage:HpMSA2324
> >> > ・FC:2台
> >> >
> >> > という構成で、 RedhatClisterSuite
> >> を稼働させてファイルサ
> >> > ーバとしてNFSのHAクラスタ構成をくんでいます。
> >> >
> >> >
> >>
> lustatコマンドで状態を確認したところクォーラムディスク
> > がOffline
> >> > のままとなっております。
> >> >
> >>
> フェンシングもフェイルオーバーも問題なく動作しているの
> > で
> >> > この状態が正しいのかわかりません?
> >> >
> >>
> 正しくないとすれば何が原因とか考えられるでしょうか?
>
> _______________________________________________
> linux-users mailing list
> linux-users@xxxxx
> http://listserv.linux.or.jp/mailman/listinfo/linux-users
>

_______________________________________________
linux-users mailing list
linux-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/linux-users


投稿者 xml-rpc : 2010年6月28日 18:06
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/96708
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。