2008年12月18日

[linux-users:108166] Re: qpopper4.0.4のバージョンアップに関しての質問

山田 と申します。

configure --helpで調べてみましょう。

APOPを使っているのか?等も分かりませんが...
/etc/shadow (/etc/passwd)を使うなら以下が必要
--enable-specialauth Enable secure crypt or shadow passwords

APOPも使うなら以下が必要
--enable-apop=path Set the pop.auth file path /etc/pop.auth

slackwareならPAMは使っていないので以下を設定
--without-pam

このあたりで解決するのではないでしょうか?

/やまだ

> お世話になります。
> OS Slackware12.0
> SMTP sendmail.8.14.3
> POP3 qpopper4.0.4
> という環境で、メールサーバーを、安定運用しております、
> 当該バージョンにて、バッファーオーバーランの脆弱性ありとの情報があり
> ver4.0.15へアップデートを行い
> sendmailの再起動
> qpopperの再起動
> # kill -HUP xxxx
> を行ったところ、全てのメールユーザの認証が、できなくなってしまいました。
> (telnet接続も、認証で失敗します)
>
> 解決方法をご教授願いできませんでしょうか。よろしくお願いいたします。
> 以上です。
>
> インストール時の、オペレーション(ver4.0.4、4.0.15共通)
> # tar zxvf qpopper4.0.xx.tar.gz
> # cd qpopper4.0.xx
> # ./configure
> # make
> # make install
>
> --------------------------------------
> Power up the Internet with Yahoo! Toolbar.
> http://pr.mail.yahoo.co.jp/toolbar/
>


投稿者 xml-rpc : 2008年12月18日 09:02
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/80178
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。