2004年11月16日

[linux-users:103827] パッケージのインストールについて教えてください

ミナガといいます。
いつも勉強させていただいております。

RedHat Linux9のデフォルトのApache2.0.40を2.0.52に
アップグレードしようとしております。

httpd-2.0.52-1.i386.rpmをrpm -Uvhでアップしようと思ったら
いろいろライブラリがないといわれ、一つ一つ追いかけました。

その中で、私としてはインストールできたと思っているのに

どうしても「まだ足りない」といわれてしまうライブラリが
あります。それは、libtcl8.3.soです。

まず、httpd-2.0.52-1.i386.rpmのインストールの際に必要と
いわれたので、compat-db-4.1.25-2.1.i386.rpmをインストール
しようとしました。が、

rpm -Uvh compat-db-4.1.25-2.1.i386.rpm
エラー: Failed dependencies:
libtcl8.4.so is needed by compat-db-4.1.25-2.1

libtcl8.4.soのためにtcl-8.4.5-7.i386.rpmをrpmでインストール
しようとすると、

rpm -Uvh tcl-8.4.5-7.i386.rpm
エラー: Failed dependencies:
libtcl8.3.so is needed by (installed) expect-5.38.0-88

といわれるので、今度はexpectを入れ、libtcl8.3.soのために
tcl-8.3.5-88.i386.rpmをインストールしました。
これも/usr/lib/libtcl8.3.soに入りました。

その後、libtcl8.4.soのためにtcl-8.4.5-7.i386.rpmをrpmでインストール
しようとすると、

rpm -Uvh tcl-8.4.5-7.i386.rpm
警告: tcl-8.4.5-7.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
エラー: Failed dependencies:
libtcl8.3.so is needed by (installed) expect-5.38.0-88

と出てきます。
libtclもexpectも入れたのにも関わらず…。
どうしたら良いでしょうか?
どなたかご教授をお願いします。
(質問に際して提示する情報が足りなかったらすみません。)


----
弥永悦子
株式会社キッズ
105-0014 東京都港区芝1-5-10 ICビル4F
tel:03-5765-2760 / fax:03-5765-2765

投稿者 xml-rpc : 2004年11月16日 16:30
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27839
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。