2010年11月11日

[gentoojp-users:02172] CFLAGS が設定されません

早間です。
app-emulation/open-vm-tools
をコンパイルしているのですが、コンパイルエラーになります。
現象は、 configure の実行で CFLAGS に -I/usr/include/glib-2.0 が
設定できないことにあるようです。つまり、この機械上での
環境
アプリケーション
の状態が正しくないと思われるのです(他の gentoo ホストではコンパイ

ルできるものがこのホストではエラーになる。x11-base/xorg-drivers も
コンパイル出来ません。)。

下記のパッケージは再インストールしました。
sys-apps/portage
sys-devel/m4
sys-devel/automake
dev-lang/python
sys-apps/sed
sys-apps/coreutils
sys-apps/sandbox
dev-libs/dbus-glib
dev-util/pkgconfig

python-updater は実行しました。

python は3.1もインストールされていますが 2.6 を使用しています。
gentoo ~ # eselect python list
Available Python interpreters:
[1] python2.6 *
[2] python3.1

/etc/make.conf に CFLAGS="-I/usr/include/glib-2.0"
設定してみましたがコンパイル時にはついていません。

インストールは
# emerge --oneshot app-emulation/open-vm-tools

で実行しています。

間違い・ヒントなどお気づきの事があれば教えて下さい。

-- 早間


投稿者 xml-rpc : 2010年11月11日 18:42
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/99960
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。