2012年6月20日

[debian-users:56203] Re: XS35V3(squeeze amd64)での音声出力について

伊坂殿へ

坂野(ばんの)です。
まちがったレスをかえしてしまったようで、すいません。

わたしも、あまり、サウンド関係に詳しくないので、
間違った箇所ありましたら、ご指摘願います。

http://wiki.linuxmce.org/index.php/Audio_over_HDMI
からすると、HDMIからの音声出力は、
Generally it's possible with kernel 2.6.27 and ALSA 1.0.18.
からのようで、カーネルのバージョンは、squeezeでも、対応できるものもあるかもしれません。
が、新しいデバイスは、認識できないように思います。

Sidなら、カーネルで認識して、切り替えられるようになっていても
良いように思いますので、まず、下記を確認下さい。

# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

 ☆できれば、lspci -nn | grep -i audio を使った方が、詳しい内容が出ていいと思います。

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 0/1
Subdevice #0: subdevice #0

のように、HDMIは、認識されているでしょうか?

また、speake-test -Dhdmi
の結果は、どうでしょうか?

ここで、
再生オープンエラー:そのようなファイルがありません。 と出るようならば、
デバイスが認識されていない。と思います。

<Redhat系での解決するまでのフォーラムのやり取り>
http://forum.linuxmce.org/index.php?topic=10906.0
は、伊坂殿と同じマシンなので、最後の方にかかれているように、
設定ファイルを修正すると良いような気がします。

1./etc/modprobe.d/sound.conf
and the
2./etc/modprobe.d/alsa-base.conf
with
options snd-hda-intel enable_msi=0 probe_mask=1,2

の修正は、たぶん、不要。

〜.asoundrc か、/etc/asound.conf に
pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia
pcm.!hdmi-remap {
type asym
playback.pcm {
type plug
slave.pcm "remap-surround71"
}
}
pcm.!remap-surround71 {
type route
slave.pcm "hw:1,3"
ttable {
0.0= 1
1.1= 1
2.4= 1
3.5= 1
4.2= 1
5.3= 1
6.6= 1
7.7= 1
}
}

と記入してみたら、どうでしょうか?
・・・すいません。ここの部分は、自信がありませんので、
   詳しい方、フォロー下さい。

以上

(追記)
たまたま、少し前に買ったのONKYOのノートパソコン(Win7)に
HDMIポートがあったので、Debian(Squeeze)を入れてみました。

サウンド関係は、若干、違います。

ikbanno@xxxxx:~$ lspci -nn|grep -i audio
00:1b.0 Audio device [0403]: Intel Corporation Cougar Point High Definition Audio Controller [8086:1c20] (rev 05)

ikbanno@xxxxx:~$ aplay -l
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: PCH [HDA Intel PCH], デバイス 0: CONEXANT Analog [CONEXANT Analog]
サブデバイス: 1/1
サブデバイス #0: subdevice #0
カード 0: PCH [HDA Intel PCH], デバイス 3: HDMI 0 [HDMI 0]
サブデバイス: 1/1
サブデバイス #0: subdevice #0

通常の安定版のカーネルでは、HDMIは、認識できていませんでしたが、
squeezeのバックポートのカーネル(3.2.0−0.bpo.2)にしてみたところ、
HDMIの音声出力デバイスが選択できるようになりました。

しかしながら、ヘッドホーンからしか、音声は、出てきませんでした。

つい先程、
http://ubuntuforums.org/showthread.php?t=1624449&highlight=hdmi+sound+shuttle+ion2
の最後の部分の情報を元に、

/etc/pulse/default.pa に
load-module module-alsa-sink device=hw:1,7

を追加したところ、液晶ディスプレイと言うかテレビ(日立Wooo)から、音声が出せるようになりました。
(なぜか、スクリーンが、勝手に、ワイドサイズでなくなるのが、少し、残念ですが)

以上


投稿者 xml-rpc : 2012年6月20日 22:51
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110986
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。