2012年6月13日

[debian-users:56189] Re: Debian Squeeze で USB 認識エラー

岩松さん。
ご指摘有難う御座います。
>
> libusb 0.1 系と1.0 で 仕様が異なるので、お使いのlibusbライブラリの
> バージョンを調べてAPIの動作を確認することをお薦めします。
>
はい。調べてみます。
私が参考にしていた情報は、usblib の仕様は旧いものだったかも知れません。

再確認しましたが、記載した日時が不明でした。

ご指摘を頂いて、以下のような記述を見つけました。有難う御座いました。

Backwards compatibility
libusb-1.0 is not backwards compatible with libusb-0.1 - all function
names are different, etc. However, libusb-1.0 is designed to be happily
installable alongside libusb-0.1 (even in the default configuration) so
the lack of backwards compatibility is not really a problem - users can
have both libusb versions present on the same system without conflict.

That said, there is a libusb-compat-0.1 compatibility layer. This is a
"wrapper" which converts libusb-0.1 function calls to their 1.0
equivalents. For more info, see libusb-compat-0.1.
--
with regards,
-----------------------
Hitoshi TANIMURA
tanimura@xxxxx
-----------------------

(2012/06/12 8:11), Nobuhiro Iwamatsu wrote:
> こんにちは。岩松です。
>
> どんなプログラムなのかわからないので想像で答えますが、
> ここで出力されているVendor / Produt id が下の方で動かしている
> プログラムで取得できてないので、システムというより作成されているプログラムに
> 何かバグがあると思われます(仕様変更に対応されてないなど)。
>
> libusb 0.1 系と1.0 で 仕様が異なるので、お使いのlibusbライブラリの
> バージョンを調べてAPIの動作を確認することをお薦めします。
>
> 岩松
>


投稿者 xml-rpc : 2012年6月13日 04:57
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110761
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。