2012年3月20日

[debian-users:56064] [Translate] [SECURITY] [DSA 2435-1] gnash security update

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- - -------------------------------------------------------------------------
Debian Security Advisory DSA-2435-1 security@xxxxx
http://www.debian.org/security/ Gabriele Giacone

March 19, 2012 http://www.debian.org/security/faq
- - -------------------------------------------------------------------------

Package : gnash
Vulnerability : 複数
Problem type : ローカル / ローカル (リモート)
Debian-specific: いいえ
CVE ID : CVE-2010-4337 CVE-2011-4328 CVE-2012-1175
Debian Bug : 605419 649384 664023

GNU Flash プレーヤ Gnash に複数の欠陥が発見されました。

CVE-2012-1175

Georgia Tech Information Security Center の Tielei Wang さんにより、
GNU Gnash に整数オーバフローに起因する欠陥が発見されました。細工し
た SWF ファイルをユーザに騙して開かせることによりヒープベースのバッ
ファオーバフローを起こす攻撃が可能です。

CVE-2011-4328

Alexander Kurtz さんにより、HTTP クッキーの管理が安全でないことが発
見されました。Cookie ファイルは /tmp ファイル以下に予測可能なファイル
名で保存されるため、ユーザに書き込み権限のあるファイルの上書きが可
能で、さらに誰からも読めるパーミッションで格納されるため情報の漏洩
を起こします。

CVE-2010-4337

Jakub Wilk さんにより、build の際の一時ファイルの管理が安全でないこ
とが発見されました。ファイルは /tmp ファイル以下に予測可能なファイル
名で保存されるため、ユーザに書き込み権限のあるファイルの上書きが可
能です。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー
ジョン 0.8.8-5+squeeze1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー
ジョン 0.8.10-5 で修正されています。

直ぐに gnash パッケージをアップグレードすることを勧めます。

Debian Security Advisories に関する説明、これらの更新をシステムに適用
する方法、FAQ などは http://www.debian.org/security/ を参照ください。

Mailing list: debian-security-announce@xxxxx
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2012年3月20日 22:57
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/109121
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。