2011年12月21日

[debian-users:55861] [Translate] [SECURITY] [DSA 2368-1] lighttpd security update

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ---------------------------------------------------------------------------
Debian Security Advisory DSA-2368-1 security@xxxxx
http://www.debian.org/security/ Nico Golde

Dec 20th, 2011 http://www.debian.org/security/faq
- ---------------------------------------------------------------------------

Package : lighttpd
Vulnerability : 複数
Problem type : リモート
Debian-specific: いいえ
Debian bug : 652726
CVE IDs : CVE-2011-4362 CVE-2011-3389

メモリ消費を最小限に抑えた小型で高速なウェブサーバ lighttpd に、複数
の問題が発見されました。

CVE-2011-4362

Xi Wang さんにより、HTTP 認証の際にユーザ入力のデコードに用いる
base64 デコード処理に、ユーザ入力処理時の符号処理誤りが発見されま
した。この欠陥を攻撃することで、lighttpd に範囲外読み出しを起こさ
せてサービス拒否攻撃を行うことが可能です。

CVE-2011-3389

SSL を有効化したヴァーチャルホストとクライアント間の通信に CBC 暗
号を用いる場合、いわゆる BEAST 攻撃による中間者攻撃が可能です。具
体的には、HTTPS セッションに対してブロック選択境界攻撃 (BCBA) を用
いて平文の HTTP トラフィックを取得可能です。技術的には、これは
lighttpd の欠陥ではありません。しかしながら、lighttpd では、CBC 暗
号を無効化することでこの問題を緩和するという回避措置を提供すること
にしました。

この更新では上記のオプションを標準で指定します。システム管理者は、
この更新の NEWS ファイルを読むことを推奨します (古いクライアントが
動かなくなっているかも知れません)。


旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は
バージョン 1.4.19+lenny3 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー
ジョン 1.4.28-2+squeeze1 で修正されています。

テスト版 (testing) ディストリビューション (squeeze) では、この問題は近
く修正予定です。 .
不安定版 (unstable) ディストリビューション (sid) では、この問題はバー
ジョン 1.4.30-1 で修正されています。


直ぐに lighttpd パッケージをアップグレードすることを勧めます。

Debian Security Advisories に関する説明、これらの更新をシステムに適用
する方法、FAQ などは http://www.debian.org/security/ を参照ください。

Mailing list: debian-security-announce@xxxxx
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2011年12月21日 20:17
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107782
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。