2011年12月 5日

[debian-users:55808] Re: Firefoxのflash-pluginについて

飛田です。

もう解決されたでしょうか?

>>>>> In [debian-users : No.55774]
>>>>> Katsuta Umeki <neutrino@xxxxx> wrote:

> 新しく購入したノートPCにsqueeze amd64をインストールし使用しています。

> firefox8を使用していますが、flash動画を見ることができません。
> adobeサイトよりflash player 11.1.102.55のlinux用tar.gzファイルをダウンロードし、
> 解凍したlibflashplayer.soを/usr/lib64/firefox/pluginsに配置しましたが、flashの再生ができません。
> iceweeselでは再生が可能です。
> 解決法をお教えください。

> 尚、firefox8はインストールしたままでは起動せず、ia32-gtkをインストールし動作可能となりました。

これを読むと、Firefox は 32bit 版を入れたにも関わらず、
libflashplayer.so を /usr/lib64 以下、つまり 64bit 版バイナリが読むとこ
ろへ配置しているように見えます。

いっそのこと、Firefox も 64bit 版を導入されたらいかがですか?

http://ftp.jaist.ac.jp/pub/mozilla.org/firefox/releases/latest/linux-x86_64/ja/

adobe の FlashPlayer も 64bit 版があるのでそれを導入すると良いように思います。

ちなみに、Firefox が読む plugin の位置はいくつかあるようですが、
libflashplayer.so は /usr/lib/mozilla/plugins/ 以下に配置しても良いと思
います。

まぁ、これだと 32bit と 64bit 版を使い分けるような用途には向いていませ
んが..

あと、deb パッケージで mozplugger を導入しておくと PDF ドキュメントへの
リンクなどは okular が Firefox 内で動いてくれたりするので便利かもしれま
せん。

--
Shinichiro HIDA shinichiro@xxxxx
GPG fingerprint = BD22 BAE5 43BA 5E70 9F1B 7627 1D81 E567 6912 F09D

投稿者 xml-rpc : 2011年12月 5日 22:44
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107698
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。