2011年12月 5日

[debian-users:55807] [Translate] [SECURITY] [DSA 2357-1] evince security update

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2357-1 security@xxxxx
http://www.debian.org/security/ Yves-Alexis Perez

December 03, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : evince
Vulnerability : 複数
Problem type : リモート
Debian-specific: いいえ
CVE ID : CVE-2010-2640 CVE-2010-2641 CVE-2010-2642 CVE-2010-2643
Debian Bug : 609534

IBM X-Force Advanced Research の Jon Larimer さんにより、evince 文書
ビューアの DVI バックエンドに複数の欠陥が発見されました。

CVE-2010-2640

PK フォントパーザで配列の添字チェックが不十分なため、関数ポインタ
の上書きによる任意のコードの実行に繋がります。

CVE-2010-2641

PK フォントパーザで配列の添字チェックが不十分なため、関数ポインタ
の上書きによる任意のコードの実行に繋がります。

CVE-2010-2642

AFM フォントパーザで、ヒープに取ったメモリバッファへのデータの書
き込みの際に配列の添字チェックが不十分なため、任意のメモリの上書
きや任意のコードの実行に繋がります。

CVE-2010-2643

メモリ割り当てサイズとして用いている整数のチェックが不十分であり、
割り当てた範囲外のメモリの上書きが行えるため、任意のコードの実行
に繋がります。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は
バージョン 2.22.2-4~lenny2 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、CVE-2010-2640,
CVE-2010-2641 および CVE-2010-2643 はバージョン 2.30.3-2 で修正されて
いますが、CVE-2010-2642 の修正は不十分です。最終的な修正はバージョン
2.30.3-2+squeeze1 で行われています。

テスト版ディストリビューション (wheezy) では、この問題はバージョン
3.0.2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー
ジョン 3.0.2 で修正されています。

直ぐに evince パッケージをアップグレードすることを勧めます。

Debian Security Advisories に関する説明、これらの更新をシステムに適用
する方法、FAQ などは http://www.debian.org/security/ を参照ください。

Mailing list: debian-security-announce@xxxxx
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2011年12月 5日 20:52
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107697
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。