2011年11月17日

[debian-users:55773] Re: クロスコンパイル環境でwarning

岩崎さま

ご説明いただきありがとうございます。
もう一度ゆっくり確認しましたら
libc.so は /usr/arm-linux-gnueabi/lib/ にあるので
11.04 の場合(waningが出る)
arm-linux-gnueabi-gcc -print-search-dires


libraries: =/usr/lib/gcc/arm-linux-gnueabi/4.5.2/:
/usr/lib/gcc/arm-linux-gnueabi/4.5.2/../../../../arm-linux-gnueabi/lib/arm-linux-gnueabi/4.5.2/:
/usr/lib/gcc/arm-linux-gnueabi/4.5.2/../../../../arm-linux-gnueabi/lib/:
<--ここにある?
/usr/lib/i386-linux-gnu/arm-linux-gnueabi/4.5.2/: <--ここと
/usr/lib/i386-linux-gnu/ <--ここが間違いと思ったが

11.10 の場合(正常)
ライブラリ: =/usr/lib/gcc/arm-linux-gnueabi/4.6.1/:
/usr/lib/gcc/arm-linux-gnueabi/4.6.1/../../../../arm-linux-gnueabi/lib/arm-linux-gnueabi/4.6.1/:
/usr/lib/gcc/arm-linux-gnueabi/4.6.1/../../../../arm-linux-gnueabi/lib/arm-linux-gnueabi/:
/usr/lib/gcc/arm-linux-gnueabi/4.6.1/../../../../arm-linux-gnueabi/lib/../lib/:
/usr/lib/gcc/arm-linux-gnueabi/4.6.1/../../../../arm-linux-gnueabi/lib/
<--ここにある

なので、検索パスだけの話ではないのかも知れません

教えていただいた
arm-linux-gnueabi-gcc -dumpspecs を見てみたんですが
まるで暗号のようで (^^;

Qt Embeddedなどをインストールしているので、arm-linux-gnuebiのバージョン
を上げたくなかったんですが、
アップグレードした方が良いのかな

--
_/_/_/_/_/_/_/_/_/_/_/_/_/_ /_/_/
斉藤

投稿者 xml-rpc : 2011年11月17日 22:43
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107415
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。