2011年10月30日

[debian-users:55739] Re: libudevパッケージについて

On Sun, 30 Oct 2011 21:06:27 +0900
野宮 賢 / NOMIYA Masaru <nomiya@xxxxx> wrote:

芳賀です。

> 芳賀さん> でも udev 関連だけ、eeze の configure が通るまで
> バージョンを上芳賀さん> げてしまうと、lenny の「システム」と
> しては、どうなっちゃうんだ芳賀さん> ろう、という危惧がちょっ

> とありますが、そこら辺、ご意見をいただ芳賀さん> けるとありが
> たいです。
>
> 確かに udev 関連をアップグレードしますと,関連するファイルの
> アップグレードも要求されました(確か,3 ファイル?).
>
> 調べましたら,
>
> http://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.en.html#upgrading-udev
>
> という記述がありました.

こういう記述ですね。

Booting the 2.6.26 kernel from lenny with the udev from
squeeze may result in a failure to correctly assign names to
network devices, and will also fail to apply certain
additional permissions to block devices (such as access by
the disk group). The software itself will appear to be
working, but some rules (for example, network-based rules)
will not be loaded properly. It is therefore strongly
recommended that you upgrade the kernel on its own at this
point, to ensure a compatible kernel is available before
upgrading udev.

つまり、udev をバージョンアップするなら、その前にカーネルの
バージョンも上げなさい、ということのようですね。
さもないと、ネットワークデバイスへの名前の割り当てに失敗すると
か、ブロックデバイスへの追加パーミッションの適用に失敗するとか
書かれてます。そのうえ、正しくロードされないルールが出てくると
も書かれてますね。

> う〜む,厄介ですねぇ〜.

まさに、おっしゃるとおり。
どうしたものか...


>
> 小生の場合,kernel は, 3.0.3 ですので,関連するファイルの
> アップグレードだけで済んだのかも知れません.
>
> ---
> ┏━━┓彡 野宮 賢 mail-to: nomiya @
> galaxy.dti.ne.jp ┃\/彡
> ┗━━┛ 「私たちが今日直面している化学物質の危険性に関する疑問
> に対し、通常の科学的な正確さをもって答えようとすれば、たぶん
> さらに数十年を要するであろ
> う。」 -- J. V.
> Rodricks --
>


--
"Thank you for telling me the truth." -- HAL9000 --
Yasufumi Haga <Yasufumi.haga@xxxxx>


投稿者 xml-rpc : 2011年10月30日 21:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107252
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。