2011年6月11日

[debian-users:55374] Re: Beautifulsoup のバグ

おはようございます。寺崎彰洋です。

On Fri, Jun 10, 2011 at 03:25 +0900,
mlus wrote:
> の意味は、aptitude で update した際に、squeeze-backports からのバージョンが入ってくる
> テストを一度でもしていれば、という意味です。(BeautifulSoapのパースのテストではありません)

「squeeze-backports からのバージョンが入ってくるテスト」の

ことだったとすると「squeeze-backports が上手く動かない。
今まで誰も backports を使用したことがないに違いない。
テストを一度でもしていれば、こんなことは起こらないのに。」と
コヤマさんは思っていらっしゃった、ということなのでしょうか。 ^^;

誰も一度も使ってみずに squeeze-backports を提供している、
などということは、さすがに無いと思いますよ。

> は、私の勘違いには違いないのですが、Beautifulsoupの解析に対する勘違いではなく、aptitude
> の使い方に対する勘違いです。私の解析したいHTML文書は、 3.2.0 よりr前のバージョンでは、必ずパースエラーを引き起こします。

なるほど。じゃ Subject: は「squeeze-backports が使えません」
とかにして BeautifulSoup の動作については触れないのが
わかりやすくて良かったのでしょうね。

> しかし、3.2 では、解析できているので、単にバージョンを上げて欲しいという要望を込めた投稿のつもりでした。

http://www.debian.org/doc/manuals/debian-faq/ch-getting.en.html#s-updatestable

ここに書いていますがセキュリティ的に問題が無ければ
stable にあるパッケージのバージョンは上がりません。
なので backports というものが存在しているのだと
思います。
--
Akihiro Terasaki


投稿者 xml-rpc : 2011年6月11日 10:33
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/104466
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。