2011年6月 1日

[debian-users:55331] [Translate] [SECURITY] [DSA 2247-1] rails security update

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2247-1 security@xxxxx
http://www.debian.org/security/ Thijs Kinkhorst

May 31, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : rails
Vulnerability : 複数の欠陥
Problem type : リモート
Debian-specific: いいえ
CVE ID : CVE-2011-0446 CVE-2011-0447
Debian Bug : 614864

Ruby ウェブアプリケーションフレームワーク Rails に、複数の問題が発見さ
れました。 The Common Vulnerabilities and Exposures project は以下の問
題を認識しています。

CVE-2011-0446

JavaScript エンコーディング有効時に複数のクロスサイトスクリプティ
ングを許す欠陥があるため、リモートの攻撃者が任意のウェブスクリプト
や HTML を挿入可能です。

CVE-2011-0447

Rails が X-Requested-With ヘッダを含む HTTP リクエストを適切に検
証していないため、リモートの攻撃者からのクロスサイトリクエストフ
ォージェリ (CSRF) 攻撃が容易になっています。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は
バージョン 2.1.0-7+lenny0.1 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー
ジョン 2.3.5-1.2+squeeze0.1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー
ジョン 2.3.11-0.1 で修正されています。

直ぐに rails パッケージをアップグレードすることを勧めます。

Debian Security Advisories に関する説明、これらの更新をシステムに適用
する方法、FAQ などは http://www.debian.org/security/ を参照ください。

Mailing list: debian-security-announce@xxxxx
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2011年6月 1日 19:27
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/104229
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。