2011年5月26日

[debian-users:55295] Re: Emacs23 がインストールできない

武藤@Debianぷろじぇくとです。

At Thu, 26 May 2011 10:54:55 +0900,
Hiroyuki Shimada wrote:
>  「Cannot open load file: poe」で検索をしましたら apel をインストールす
> るとエラーが出なくなるというページを見つけましたので、apel をインストー
> ルしてみました。すると、emacs23 の設定はうまくいきましたが、今度は apel
> パッケージの設定がうまくいきません。


> apel (10.8-1) を設定しています ...
> install/apel: byte-compiling for emacs20, logged in /tmp/elc.NrPhqGizFs7c
> emacs-package-install: /usr/lib/emacsen-common/packages/install/apel emacs20 emacs20 emacs21 emacs23 xemacs21 failed at /usr/lib/emacsen-common/emacs-package-install line 30, <TSORT> line 1.
> dpkg: apel の処理中にエラーが発生しました (--configure):
> サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 1 を返しました
> configured to not write apport reports

依存関係で入れっぱなしだけど実はemacs20に対応していない、ということでは
ないですかね。
emacs20パッケージが必要なければこれを削除。xemacs21も使っていなければ
削除したほうがよいかと思います。

emacs20、emacs21、emacs23、xemacs21とたくさん入れていたり、さまざまな
lispパッケージも入れたままお使いのようですが、少し環境を整理したほうが
よいかと思います。今後とも古いパッケージでつまらないトラブルに見舞われる
可能性が高いでしょう。
--
武藤 健志@ kmuto @ kmuto.jp
Debian/JPプロジェクト (kmuto@xxxxx, kmuto@xxxxx)
株式会社トップスタジオ (kmuto@xxxxx)
URI: http://kmuto.jp/ (Debianな話題など)


投稿者 xml-rpc : 2011年5月26日 11:22
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/104028
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。