2009年11月28日

[debian-users:53386] Re: CUPSのDigest認証

mejikoです。返信ありがとうございます。
>
> CUPS 1.3.8までのバグだったかと思います。
> lpadminなどのlibcupsにリンクされたコマンドツールだと問題ないのですが、
> Defaultのフォールバックの機構に問題があり、1.3.9で修正されていますね。
> 1.3.8での回避方法としては「AuthType Defaultの代わりにAuthType Digestと
> 明示的に設定する」です。

試しにすべての「AuthType」を「Default」から明示的に「AuthType Digest」としてみました。しかしやはりプリンタを認識しません。
「Authorized using Basic, expected Digest!」というエラーが数回発生してしまいます……。

不思議な事に「AuthType BasicDigest」または「DefaultAuth BasicDigest」かつ「AuthType Default」な時は認識します。

ということで、元に戻しておきました。うーん、やはりこのバグと関係があるのでしょうかね?


あと確か「/usr/share/doc/libcups2/README.Debian.gz」を読む限り、DebianのCUPSって、デフォルトでSSLがサポートされていないんですよね。
もしかしてGNUTLSもサポートされていないのですかね? となれば、CUPSで暗号化通信は「再コンパイル」しないとできないということになりますか? 
勘違いであればすいません。

そんでもって「https」でcupsのウェブインターフェイスに接続すると、iceweaselでは「sec_error_untrusted_issuer」エラーが゜発生。
CUPSのログには「Unable to encrypt connection from localhost!」というログが残っていました。

投稿者 xml-rpc : 2009年11月28日 18:01
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/90869
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。