2009年11月24日

[debian-users:53357] 古いコードネームのついたパッケージ

塩路@横浜国大と申します。

特段困っているわけではないのですが、気にかかっていることを
お尋ね致します。

potato(もしかしたらwoody)の頃からlennyまでバージョンアップを続けている
PCで

dpkg -l|egrep 'woody|sarge|etch'

を実行してみると、以下のように結構引っかかります。

ii libapr0 2.0.54-5sarge2 the Apache Portable Runtime
ii libavcodeccvs51 3:20060305-0.1sarge1 library to encode decode multimedia streams - runtime
ii libavutilcvs49 3:20060305-0.1sarge1 avutil shared libraries
ii libcupsys2-gnutls10 1.2.7-4+etch8 Common UNIX Printing System(tm) - dummy libs for trans
ii libdevmapper1.01 2:1.01.00-4sarge1 The Linux Kernel Device Mapper userspace library
ii libdns16 1:9.2.4-1sarge3 DNS Shared Library used by BIND
ii libdns5 1:9.2.1-2.woody.2 DNS Shared Library used by BIND
ii libgnutls11 1.0.16-13.2sarge2 GNU TLS library - runtime library
ii libgnutls13 1.4.4-3+etch4 the GNU TLS library - runtime library
ii libicu36 3.6-2etch3 International Components for Unicode (libraries)
ii libisc4 1:9.2.1-2.woody.2 ISC Shared Library used by BIND
ii libisc7 1:9.2.4-1sarge3 ISC Shared Library used by BIND
ii libkpathsea3 2.0.2-30sarge5 path search library for teTeX (runtime part)
ii liblwres1 1:9.2.4-1sarge3 Lightweight Resolver Library used by BIND
ii libmagick9 7:6.2.4.5.dfsg1-0.15+etch1 Image manipulation library
ii libmyspell3c2 1:3.1-18etch1 MySpell spellchecking library
ii libmysqlclient12 4.0.24-10sarge3 mysql database client library
ii libnss3-0d 1.8.0.15~pre080614i-0etch1 Network Security Service libraries
ii libpoppler0c2 0.4.5-5.1etch3 PDF rendering library
ii libpostproccvs51 3:20060305-0.1sarge1 postproc shared libraries
ii libssl0.9.6 0.9.6m-1sarge5 SSL shared libraries (old version)
ii libssl0.9.7 0.9.7k-3.1etch5 SSL shared libraries
ii libssl09 0.9.4-6.woody.3 SSL shared libraries (old version)
ii libtasn1-2 0.2.10-3sarge1 Manage ASN.1 structures (runtime)
ii libtiff3g 3.5.5-6.woody2 Tag Image File Format library
ii libxvidcore4 2:1.1.0-beta2+cvs-0.0sarge1 High quality ISO MPEG4 codec library
ii ntp-simple 1:4.2.2.p4+dfsg-2etch3 transition package
ii php4-common 6:4.4.4-8+etch6 Common files for packages built from the php4 source
ii python2.1 2.1.3dfsg-1sarge1 An interactive high-level object-oriented language (ve
ii xfonts-pex 4.1.0-16woody4 fonts for minimal PEX support in X
ii xlibmesa-dri 1:7.1.0-19 transitional package for Debian etch
ii xlibmesa-gl 1:7.3+20 transitional package for Debian etch
ii xlibmesa-glu 1:7.3+20 transitional package for Debian etch


apt-get upgradeではアップグレードできるものは出てこないのですが、
こういうものはそのままにしておいてもいいものなのでしょうか?
(古いコードネームのついたパッケージを問題なくなくしてしまう方法は
あるのでしょうか?)

これらのパッケージひとつひとつが本当に必要なものなのかどうかという
判断は自分ではなかななつきません。
先にも書いた通り、現在のところ特に困ってはいませんが、
そのうちバージョンアップできなくなるのではないかという
不安はあります。

塩路


投稿者 xml-rpc : 2009年11月24日 21:12
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/90778
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。