2009年11月24日

[debian-users:53356] [Translate] [SECURITY] [DSA 1938-1] New php-mail packages fix insufficientinput sanitising

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ------------------------------------------------------------------------
Debian Security Advisory DSA-1938-1 security@xxxxx
http://www.debian.org/security/ Steffen Joeris

November 23, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : php-mail
Vulnerability : プログラムミス
Problem type : リモート
Debian-specific: いいえ
CVE Id : No CVE id yet

電子メール送信のための PHP PEAR モジュール php-mail の入力のサニタイズ
が不十分であり、php-mail を使っているシステムから機密情報を取得可能で
あることが発見されました。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ
ン 1.1.14-1+lenny1 で修正されています。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー
ジョン 1.1.6-2+etch1 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題は近く修正予定で
す。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ
ョン 1.1.14-2 で修正されています。

直ぐに php-mail パッケージをアップグレードすることを勧めます。


アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。


Debian GNU/Linux 4.0 alias etch
- -------------------------------

Debian (old stable)
- ------------------

旧安定版の更新は、alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel,
powerpc, s390 および sparc の各アーキテクチャで提供されています。
.
ソースアーカイブ:

http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6.orig.tar.gz
Size/MD5 checksum: 13702 47b38a06acdec73c4d8c01f9d7e5e8e2
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.diff.gz
Size/MD5 checksum: 3310 64425237844fed79a4b71aa34ccb0cee
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.dsc
Size/MD5 checksum: 689 93c32b0cb655191ac6edb48013d18921

アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1_all.deb
Size/MD5 checksum: 17884 a2abda15da9ddab5f1590198cc852b3f


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Debian (stable)
- ---------------

安定版の更新は、alpha, amd64, arm, hppa, i386, ia64, mips, mipsel,
powerpc, s390 および sparc の各アーキテクチャで提供されています。
.
ソースアーカイブ:

http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.dsc
Size/MD5 checksum: 1258 6d361bf9406e9195813b4396bb7d5c13
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14.orig.tar.gz
Size/MD5 checksum: 17537 e50da58b6b787b3903ce4d07dc791bb2

http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.diff.gz
Size/MD5 checksum: 4105 a8154d9e86e98a591dfc9e84210ce163

アーキテクチャに依存しないパッケージ:


http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1_all.deb
Size/MD5 checksum: 21904 d5184514df44b348582071748e855c32


これらのファイルは次の版の安定版リリース時そちらに移されます。


- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2009年11月24日 21:05
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/90768
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。