2009年11月17日

[debian-users:53330] mysql-server-5.1 --> mysql-server-5.0 へのダウングレード

橋本といいます。
GigaLandisk(HDL-G)にlennyをインストールして使用しています。

LennyのMYSQLサーバのバージョンは5.0.51aですが5.1を使う必要ができたため
/etc/apt/sources.list へ

deb http://www.backports.org/debian lenny-backports main

を書き加えbackportsのmysql-server-5.1をインストールしました。

# aptitude update
# aptitude install mysql-server-5.1

インストールは無事成功したのですが、phpmyadminを使うと「使用するライブラ
リが5.0.51aの物だから予期せぬ動作をするかもしれない」と言うような警告が
表示されたので5.1 --> 5.0 へダウングレードすることにしました。

そこで先ほど書く加えた

deb http://www.backports.org/debian lenny-backports main

を削除し

# aptitude update
# aptitude install mysql-server-5.0

を実行しました。
が下記のような表示がされて5.0のインストールが失敗してしまいました。

# -------------------------------------------------------------------



(.../mysql-server-5.0_5.0.51a-24+lenny2_arm.deb から) mysql-server-5.0
を展開しています...
Aborting downgrade from (at least) 5.1 to 5.0.
dpkg: /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny2_arm.deb
の処理中にエラーが発生しました (--unpack):
サブプロセス pre-installation script はエラー終了ステータス 1 を返しま
した
未選択パッケージ mysql-server を選択しています。
(.../mysql-server_5.0.51a-24+lenny2_all.deb から) mysql-server を展開し
ています...
以下のパッケージの処理中にエラーが発生しました:
/var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny2_arm.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
パッケージをインストールできませんでした。復旧を試みています:
libmysqlclient15off (5.0.51a-24+lenny2) を設定しています ...
libnet-daemon-perl (0.38-1.1) を設定しています ...
libplrpc-perl (0.2017-1.1) を設定しています ...
dpkg: 依存関係の問題により mysql-server の設定ができません:
mysql-server は以下に依存 (depends) します: mysql-server-5.0 ...しかし:
パッケージ mysql-server-5.0 はまだインストールされていません。
dpkg: mysql-server の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
libdbi-perl (1.605-1) を設定しています ...
libdbd-mysql-perl (4.007-1) を設定しています ...
mysql-client-5.0 (5.0.51a-24+lenny2) を設定しています ...
以下のパッケージの処理中にエラーが発生しました:
mysql-server



# -------------------------------------------------------------------

mysql関連のパッケージを

dpkg -l | grep mysql


で検索し表示されたパッケージ

libdbd-mysql-perl 4.007-1
libmysqlclient15-dev 5.0.51a-24+lenny2
libmysqlclient15off 5.0.51a-24+lenny2
libmysqlclient16 5.1.37-2~bpo50+1
mysql-client-5.0 5.0.51a-24+lenny2
mysql-client-5.1 5.1.37-2~bpo50+1
mysql-common 5.1.37-2~bpo50+1
mysql-server 5.0.51a-24+lenny2
mysql-server-5.1 5.1.37-2~bpo50+1
php5-mysql 5.2.6.dfsg.1-1+lenny3
zabbix-server-mysql 1:1.4.6-1

を全て削除した後、再度

# aptitude install mysql-server-5.0

を行って見ましたが同じように

Aborting downgrade from (at least) 5.1 to 5.0.

と表示されて失敗してしまいます。

ダウングレードの仕方がまずかったのだと思いますがこの場合のダウングレード
を成功させるにはどのような手順を踏めば良いのでしょうか。

どなたかアドバイスをいただけると非常に助かります。
宜しくお願いいたします。


--
Yukio Hashimoto
scebai@xxxxx
What is 'SCEBAI' ?
(Science Chemical Electronics
Biochemical Aerospace Industries)


投稿者 xml-rpc : 2009年11月17日 13:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/90466
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。